Bug 438547 - nas: pkg split
nas: pkg split
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nas (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 460986 (view as bug list)
Depends On:
Blocks: F9Target KDE4Live 439255
  Show dependency treegraph
 
Reported: 2008-03-21 14:32 EDT by Rex Dieter
Modified: 2010-10-22 19:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 14:44:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-03-21 14:32:47 EDT
Slightly in the same vein as bug #253748 (not start nasd by default), but this 
is more along the lines if introducing a package split for functionality and 
space savings.  What I'd propose to be considered is a new -libs subpkg that 
contains libasound.so.* only.

This provides a few benefits:
1.  apps linking against nas wouldn't pull in any extra baggage (payoff being 
space saved for live images)
2.  -libs split makes multilib easier
3.  nasd would be installed/started by default only when main 'nas' pkg is 
installed, for those who want it.
Comment 1 Rex Dieter 2008-04-07 14:26:18 EDT
working on importing into rawhide.
Comment 2 Rex Dieter 2008-04-07 14:44:28 EDT
%changelog
* Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.9.1-4
- -libs subpkg (f9+, #438547)
- %%install: INSTALLFLAGS='-p' (preserve timestamps)
- fixup %%changelog whitespace
Comment 3 Bob Relyea 2009-01-13 18:03:17 EST
*** Bug 460986 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.