Bug 3193

Summary: iBCS emulation displays "SIG: sigpending lied" continuously
Product: [Retired] Red Hat Linux Reporter: Rob Landry <rlandry>
Component: kernelAssignee: Cristian Gafton <gafton>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: deweesrx
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rob Landry 1999-06-01 13:24:34 UTC
When invoking a program that requires iBCS
emulation, the message "SIG: sigpending lied"
display constantly on the console until the program is
terminated. The message was traced to the
/usr/src/linux/kernel/signal.c file. I am unable to
determine the solution to the problem so I simply
commented out the message. After relinking the kernel the
system seems to operate normally.  However, somebody needs
to figure out the actual cause of the problem an effect
repairs.  I don't require a fix at this time. I just wanted
to report the problem (bugzilla is a bitch to use)

Comment 1 Rob Landry 1999-06-01 13:26:59 UTC
Posted per customer who entered bug in support system.

Comment 2 Michael K. Johnson 1999-07-29 21:48:59 UTC
This is flagged as a "sanity check".  We probably need to find out
whether all or only some iBCS programs cause this.  Alan, I presume
that you are the best one of us to deal with this...