Bug 3193 - iBCS emulation displays "SIG: sigpending lied" continuously
iBCS emulation displays "SIG: sigpending lied" continuously
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-01 09:24 EDT by Rob Landry
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 1999-06-01 09:24:34 EDT
When invoking a program that requires iBCS
emulation, the message "SIG: sigpending lied"
display constantly on the console until the program is
terminated. The message was traced to the
/usr/src/linux/kernel/signal.c file. I am unable to
determine the solution to the problem so I simply
commented out the message. After relinking the kernel the
system seems to operate normally.  However, somebody needs
to figure out the actual cause of the problem an effect
repairs.  I don't require a fix at this time. I just wanted
to report the problem (bugzilla is a bitch to use)
Comment 1 Rob Landry 1999-06-01 09:26:59 EDT
Posted per customer who entered bug in support system.
Comment 2 Michael K. Johnson 1999-07-29 17:48:59 EDT
This is flagged as a "sanity check".  We probably need to find out
whether all or only some iBCS programs cause this.  Alan, I presume
that you are the best one of us to deal with this...

Note You need to log in before you can comment on or make changes to this bug.