Bug 321171

Summary: sealert's dialog after update is higly confusing
Product: [Fedora] Fedora Reporter: Lubomir Kundrak <lkundrak>
Component: setroubleshootAssignee: John Dennis <jdennis>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: adrin.jalali, bnocera, davidz, richard
Target Milestone: ---Keywords: EasyFix
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: setroubleshoot-2.0.1-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-09 13:55:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    
Attachments:
Description Flags
Patch to make restart timer dialog not so scary
none
screenshot during yum udpate - errgh - none

Description Lubomir Kundrak 2007-10-06 02:48:48 EDT
Description of problem:

The message in the dialog after update of selinux troubleshooter is higly
confusing: sealert package update detected, restart? It is not clear whether the
whole operating system would be restarted or just the daemon, ordinary user is
even not aware of. Especially windows users might assume that the whole machine
is to be restarted.

Is this dialog even needed at all? It is confusing, it doesn't comply with good
human interface design practices and probably not even needed at all.

Please reconsider it, thanks!
Comment 1 Lubomir Kundrak 2007-11-16 05:09:45 EST
Ping
Comment 2 John Dennis 2007-11-16 09:03:14 EST
Yes, this can be changed, we're preparing version 2 of setroubleshoot, and we'll
fold this in at that time.

The reason for the dialog was because the GUI component (sealert) of
setroubleshoot needs to restart if the daemon (setroubleshootd) is upgraded. It
was felt if would be equally confusing to the user to have his application
disappear and come back, especially if you were actively using it.
Comment 3 Paul W. Frields 2007-11-22 12:15:13 EST
Created attachment 267121 [details]
Patch to make restart timer dialog not so scary

This is an alarming enough dialog that, unless the ETA for version 2 is "any
minute now," it should really be fixed with an errata update.  (Q.v. Hughes'
blog entry at http://hughsient.livejournal.com/47516.html for example.)  AFAICT
the patch is simple.
Comment 4 Máirín Duffy 2007-11-22 20:20:23 EST
This dialog doesn't steal focus, does it?

What is the chance that someone is using sealert at the same time that they
(perhaps actively) decided to upgrade setroubleshoot? Isn't the chance quite
higher that, at any given time, someone is more likely to not be using it? If
so, and if this dialog steals focus from all users, it seems to be causing an
inconvenience at best to the majority of users for the benefit of a minority.

How do other daemons handle upgrades? Do they normally automatically restart on
upgrade? Wouldn't that be a problem for things like web and network services?

How about if you detect an upgrade is available, and if sealert's main window is
open.... wait until it is closed so you know it's not being actively used and
*then* restart. you might have the icon disappear on users for a few moments
then but maybe you could change the icon to some kind of rotating arrow thing as
a kind of countdown before you restarted it so if they did notice they would
assume it was upgrading?
Comment 5 David Timms 2007-12-08 21:29:20 EST
Created attachment 282161 [details]
screenshot during yum udpate - errgh - 

DVD iso upgraded F7 to F8. 
Ran yum update.
Happened to walk past the machine 15 minutes into the update ...
Slight panic for me to, until realizing I could cancel and do the restart
later.

My immediate concern: OK, 200/607 parts of the way through a yum update and the
machine is about the reboot - how screwed will that leave my system ?

So yeah. Even the smallest of textual additions to state the se bits only need
to be restarted would reduce this to reasonable. Even better to only warn if
the  involved UI is being run at that time {or did I have it running - sorry -
not sure if the sealert item in the task bar is for the dialog or not}.

Another alternative would be to just restart the bits that need to, and send it
a message - to it's status bar to say: 'date time: GUI was restarted so that
updated components would become active.'

I dropped a shutdown dialog into the image - to compare the "Restart" text.
Comment 6 John Dennis 2008-01-09 13:55:56 EST
The restart dialog has been completely removed. Sealert quietly restarts on
daemon update without notification.
Comment 7 Fedora Update System 2008-01-15 17:54:45 EST
setroubleshoot-2.0.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'
Comment 8 Fedora Update System 2008-02-25 21:19:12 EST
setroubleshoot-plugins-2.0.4-3.fc8,setroubleshoot-2.0.5-2.fc8 has been submitted as an update for Fedora 8
Comment 9 Fedora Update System 2008-02-28 16:43:23 EST
setroubleshoot-plugins-2.0.4-3.fc8, setroubleshoot-2.0.5-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 cje 2008-03-03 20:37:56 EST
i got a pair of these popups on every f8 system i updated over the weekend. 
looks like i picked up setroubleshoot-2.0.5-2.fc8 along with
selinux-policy-3.0.8-87.fc8.

this is the first time i've seen the dialog since that one time in november. 
are you sure you don't mean "completely added back in" in comment #6 ?  ;-)
Comment 11 John Dennis 2008-03-04 09:57:23 EST
re comment #10, The dialog was completely removed, you'll never see it again.
What's going on is an installation ordering issue. The old sealert GUI is still
running. Until it's shutdown and restarted you'll get the old behavior.
Unfortunately there is no way for rpm to stop and restart session services and
as a consequence you'll just have to live with the dialog one last time. Or you
could shutdown the sealert service prior to installation (noted in the update
release notes).
Comment 12 John Dennis 2008-03-08 10:16:11 EST
*** Bug 436593 has been marked as a duplicate of this bug. ***