This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 324301

Summary: can't unlock keyring
Product: [Fedora] Fedora Reporter: Edouard Bourguignon <madko>
Component: gnome-keyring-managerAssignee: Alexander Larsson <alexl>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-11 09:28:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235703    

Description Edouard Bourguignon 2007-10-09 02:45:19 EDT
Description of problem:

The window asking for your general keyring password is now broken, you can't
type your password and so you can't unlock your keyring. 

Version-Release number of selected component (if applicable):

gnome-keyring-2.20-4.fc8
gnome-keyring-pam-2.20-4.fc8
gnome-keyring-manager-2.20.0-1.fc8

How reproducible:

static

Steps to Reproduce:
1. run gnome-keyring-manager (or any app using the gnome-keyring)
2. a window asking to unlock your keyring appears
3. you can't type anything this windows is not fully drawn and desktop is frozen
4. have to kill that window

  
Actual results:

apps using the gnome-keyring are enable to access your keyring because it's not
possible to unlock it.

Expected results:

should be able to unlock the keyring

Additional info:

sorry I don't know how to be more helpfull.
Comment 1 Alexander Larsson 2007-10-09 09:39:26 EDT
Can you upgrade to 2.20-4.f8 and test. We fixed a bunch of problems.
Also, if your ~/.gnome2/keyrings/default file is 0 bytes, do:
echo -n default > ~/.gnome2/keyrings/default
Comment 2 Edouard Bourguignon 2007-10-09 10:32:22 EDT
where can i find gnome-keyring-manager-2.20-4.f8? can't find it in koji
All my other gnome-keyring-* are already in 2.20-4

you mean  ~/.gnome2/keyrings/default or ~/.gnome2/keyrings/default.keyring?
I only have default.keyring and it's not empty
Comment 3 Matthias Clasen 2007-10-10 09:20:32 EDT
Alex meant gnome-keyring-2.20-4.f8

And ~/.gnome2/keyrings/default (without extension)

default.keyring is the actual keyring, default is a text file containing the
name of the default keyring.
Comment 4 Edouard Bourguignon 2007-10-10 12:51:37 EDT
gnome-keyring-2.20-4 was already installed and now after upgrade:

[madko@Alcyone ~]$ rpm -qa|grep keyring
gnome-keyring-2.20-5.fc8
gnome-keyring-manager-2.20.0-1.fc8
gnome-keyring-pam-2.20-5.fc8
[madko@Alcyone ~]$ ls .gnome2/keyrings/
default  default.keyring
[madko@Alcyone ~]$ cat .gnome2/keyrings/default
default[madko@Alcyone ~]$ 

The only change I can notice is the fact that the uncompletely drawn window
frozing my desktop and asking for keyring pass appears a second time when I kill it.
Comment 5 Matthias Clasen 2007-10-11 09:22:48 EDT
Which version of glibc are you using ? 
The was a bug fix in glibc recently that solved some hang issues with the the
gnome-keyring dialog. 

Can you try again with the latest glibc, please ?
Comment 6 Alexander Larsson 2007-10-11 09:28:31 EDT
This is a dup of bug 321761, which is a glibc gettext locking bug.

*** This bug has been marked as a duplicate of 321761 ***
Comment 7 Edouard Bourguignon 2007-10-11 10:15:06 EDT
i'm using the glibc-2.6.90-17, i will try with glibc-2.6.90-18 asap
Comment 8 Edouard Bourguignon 2007-10-12 02:39:29 EDT
thanks, works great with glibc-2.6.90-18