Bug 321761 - gettext problem with recent glibc builds
Summary: gettext problem with recent glibc builds
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 317921 322151 324301 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-10-07 04:17 UTC by sangu
Modified: 2007-11-30 22:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 00:44:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sangu 2007-10-07 04:17:04 UTC
Description of problem:
LANG=ko_KR.UTF-8
After selecting nabi on im-chooser, I can't input hangul with nabi.

$ cat .xinputrc
XIM=nabi
XIM_PROGRAM=nabi
GTK_IM_MODULE=xim

Version-Release number of selected component (if applicable):
0.18-7.fc8

How reproducible:
always

Steps to Reproduce:
1. nabi on im-chooser
2. logout and login
3. input hangul
  
Actual results:


Expected results:


Additional info:
im-chooser-0.5.2-3.fc8

Comment 1 subhransu behera 2007-10-08 06:05:04 UTC
Hi Sangu,

Try pressing "Shift-Space" after opening the text editor.

Comment 2 Jens Petersen 2007-10-08 06:15:38 UTC
Works for me too, even from ja_JP.UTF-8 desktop with gedit.

Comment 3 Jens Petersen 2007-10-08 06:19:46 UTC
Actually I can reproduce this under ko_KR.UTF-8 desktop:
nabi does not seem to appear - strange!

Comment 4 Jens Petersen 2007-10-08 06:40:03 UTC
Wonder if nabi-0.19 helps with this problem?

Comment 5 Jens Petersen 2007-10-08 07:07:53 UTC
doesn't seem to help...

Comment 6 sangu 2007-10-09 12:59:26 UTC
$strace nabi 
strace file : http://hellocity.net/~sangu/etc/nabi.txt

After removing /usr/share/locale/ko/LC_MESSAGES/nabi.mo,
/usr/share/locale/ko/LC_MESSAGES/glib20.mo, nabi works well on ko_KR.UTF-8




Comment 7 sangu 2007-10-10 02:21:56 UTC
LANG=ko_KR.UTF-8
$rpm -q glibc
glibc-2.6.90-17
$gdb nabi
[...]
(gdb) bt
#0 0x0012d402 in __kernel_vsyscall ()	
#1 0x00c880d9 in __lll_lock_wait () from /lib/libpthread.so.0	
#2 0x00c84afc in pthread_rwlock_rdlock () from /lib/libpthread.so.0
#3 0x0090bd95 in _nl_find_msg (domain_file=0x9b30b48,
domainbinding=0x86a2008, msgid=0x8069258 "2 set", convert=1, 
lengthp=0xbfc20aa4) at dcigettext.c:854
#4 0x0090c8ab in __dcigettext (domainname=0x86a2030 "nabi",
msgid1=0x8069258 "2 set", msgid2=0x0, plural=0, n=0, category=5)
at dcigettext.c:639
#5 0x0090b703 in *__GI___dcgettext (domainname=0x0, msgid=0x8069258 "2 set",
category=5) at dcgettext.c:53
#6 0x08057b76 in nabi_app_create_palette () at ui.c:1217
#7 0x0805e432 in main (argc=1, argv=0xbfc20bf4) at main.c:115
#8 0x008fe3a0 in __libc_start_main (main=0x805e370 , argc=1,
ubp_av=0xbfc20bf4, init=0x8068fc0 <__libc_csu_init>,
fini=0x8068fb0 <__libc_csu_fini>, rtld_fini=0x11e930 <_dl_fini>,
stack_end=0xbfc20bec) at libc-start.c:220
#9 0x0804eb61 in _start ()

After downgrading to glibc-2.6.90-15, nabi works well.

Is this glibc-2.6.90-17 bug?

Comment 8 Jens Petersen 2007-10-10 02:48:56 UTC
Thanks, Sangu, for investigating - I just reproduced the backtrace too.

Problem also seems to happen with glibc-2.6.90-16.

Comment 9 Mamoru TASAKA 2007-10-10 03:01:12 UTC
bug 317921 seems related to this.

Comment 10 Alexander Larsson 2007-10-10 09:08:37 UTC
*** Bug 322151 has been marked as a duplicate of this bug. ***

Comment 11 Jakub Jelinek 2007-10-10 09:15:39 UTC
Self-contained testcase:
#include <dlfcn.h>
#include <libintl.h>
#include <locale.h>
#include <malloc.h>

int
main (void)
{
  mallopt (M_PERTURB, 152);
  dlopen ("libpthread.so.0", RTLD_LAZY);
  setlocale (LC_ALL, "ja_JP.UTF-8");
  textdomain ("libc");
  dgettext (NULL, "Hangup");
  return 0;
}

link with -ldl, but not -lpthread.

Comment 12 Mamoru TASAKA 2007-10-10 12:26:30 UTC
*** Bug 317921 has been marked as a duplicate of this bug. ***

Comment 14 Mamoru TASAKA 2007-10-11 05:37:40 UTC
gdm hang problem with scim-python (bug 317921) seems fixed
by glibc 2.6.90-18.

Comment 15 Jens Petersen 2007-10-11 06:17:40 UTC
Yes, -18 looks okay to me too. :)

Comment 16 Kjartan Maraas 2007-10-11 07:27:23 UTC
and now unlocking the keyring works too :-)

Comment 17 Kjartan Maraas 2007-10-11 08:16:14 UTC
But, building ORBit2 with this release gives me:

 gcc -DHAVE_CONFIG_H -I. -I../.. -I../../linc2/include -I../../linc2/include
-pthread -I/opt/gnome2/include/glib-2.0 -I/opt/gnome2/lib/glib-2.0/include -Wall
-Wunused -Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED
-D_GNU_SOURCE -Wall -g -O0 -D_FORTIFY_SOURCE=2 -Wall -g -O0 -D_FORTIFY_SOURCE=2
-Werror-implicit-function-declaration -MT linc.lo -MD -MP -MF .deps/linc.Tpo -c
linc.c  -fPIC -DPIC -o .libs/linc.o
In file included from linc-compat.h:25,
                 from linc.c:22:
/usr/include/netinet/tcp.h:236: error: field 'tcpm_addr' has incomplete type
make[3]: Leaving directory `/home/kmaraas/cvs/gnome/ORBit2/linc2/src'
make[2]: Leaving directory `/home/kmaraas/cvs/gnome/ORBit2/linc2'
make[1]: Leaving directory `/home/kmaraas/cvs/gnome/ORBit2'
make[3]: *** [linc.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Comment 18 Alexander Larsson 2007-10-11 13:28:32 UTC
*** Bug 324301 has been marked as a duplicate of this bug. ***

Comment 19 Jens Petersen 2007-10-12 00:44:43 UTC
glibc-2.6.90-18 is now in rawhide.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.