Bug 328

Summary: Tripwire 1.2-1 in powertools 5.2
Product: [Retired] Red Hat Powertools Reporter: ian.clark
Component: 9wmAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.1CC: ian.clark
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-13 01:12:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ian.clark 1998-12-07 15:07:32 UTC
Just downloaded and installed Tripwire from the powertools
5.2 directory. Upon installation it started running itself
in initialise mode i assume, but left no database files

So I ran it manually as root with -v -initialise options
it then generates the directory /etc/databases and starts
scanning the files (using the standard /etc/tw.config).

It runs for a few minutes then crashes with a segmentation
fault :-

scanning: /usr/lib/linuxconf/images/vpolicies.xpm
scanning: /usr/lib/linuxconf/images/vpopuser.xpm
scanning: /usr/lib/linuxconf/images/Aloita.gif
scanning: /usr/lib/linuxconf/images/Apua.gif
scanning: /usr/lib/linuxconf/images/Ei.gif
scanning: /usr/lib/linuxconf/images/Hyvdksy.gif
Segmentation fault

Whats going wrong?


Comment 1 David Lawrence 1998-12-09 16:06:59 UTC
I got the same behavior.  segfaulted  at the same point as reporter's

Comment 2 Tim Powers 2000-01-13 01:12:59 UTC
Don't rerun the initialize! It will dump core. This same thing was happening in
the RHCE courses, I rebuilt the package without initialize and it worked *since*
they initialized the db by hand. Here is what is happening in theposktinhstall
of tripwire:

cd /var/spool/tripwire
(/usr/sbin/tripwire -initialize 2>&1 | \
/bin/mail -s "Tripwire initialization report" root ) \
&& mv databases/tw.db_* . && rm -rf databases &