Bug 328 - Tripwire 1.2-1 in powertools 5.2
Tripwire 1.2-1 in powertools 5.2
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: 9wm (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-07 10:07 EST by ian.clark
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-12 20:12:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ian.clark 1998-12-07 10:07:32 EST
Just downloaded and installed Tripwire from the powertools
5.2 directory. Upon installation it started running itself
in initialise mode i assume, but left no database files
anywhere.

So I ran it manually as root with -v -initialise options
it then generates the directory /etc/databases and starts
scanning the files (using the standard /etc/tw.config).

It runs for a few minutes then crashes with a segmentation
fault :-

scanning: /usr/lib/linuxconf/images/vpolicies.xpm
scanning: /usr/lib/linuxconf/images/vpopuser.xpm
scanning: /usr/lib/linuxconf/images/Aloita.gif
scanning: /usr/lib/linuxconf/images/Apua.gif
scanning: /usr/lib/linuxconf/images/Ei.gif
scanning: /usr/lib/linuxconf/images/Hyvdksy.gif
Segmentation fault

Whats going wrong?

Ian
Comment 1 David Lawrence 1998-12-09 11:06:59 EST
I got the same behavior.  segfaulted  at the same point as reporter's
system.
Comment 2 Tim Powers 2000-01-12 20:12:59 EST
Don't rerun the initialize! It will dump core. This same thing was happening in
the RHCE courses, I rebuilt the package without initialize and it worked *since*
they initialized the db by hand. Here is what is happening in theposktinhstall
of tripwire:

cd /var/spool/tripwire
(/usr/sbin/tripwire -initialize 2>&1 | \
/bin/mail -s "Tripwire initialization report" root ) \
&& mv databases/tw.db_* . && rm -rf databases &

Tim

Note You need to log in before you can comment on or make changes to this bug.