This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 330641

Summary: Only one attempt to retrieve stage2.img?
Product: [Fedora] Fedora Reporter: Stepan Kasal <kasal>
Component: anacondaAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 8CC: jp
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-24 14:15:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description Stepan Kasal 2007-10-13 10:21:28 EDT
I'm trying to upgrade using a minimal boot cd.
When I arrived to a http server specification, I made a typo and the install
promptly answered that the stage2.img cannot be retrieved.
After a couple of attempts I got the name of the directory right and the
installer has indeed downloaded the img (the time corresponded to the speed of
my connection).
But when the file has arrived, the loop mount failed: tty3 says:
   LOOP_SET_FD failed: Device or resource is busy.

Is it possible that the fd is busy because of the previous attempt(s)?
Would you be so kind to check this code path?

(When the http URL was correct from the beginning, this loop mount worked.)
Comment 1 Jeremy Katz 2007-10-22 16:10:32 EDT
*** Bug 335131 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2007-10-24 14:15:53 EDT
This will be fixed in the next build of anaconda for both rawhide and F8.