Bug 333261

Summary: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: ffesti, james.antill, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-19 09:01:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    

Description Nicolas Mailhot 2007-10-15 18:33:43 EDT
#  yum clean all; yum -y update
Loading "skip-broken" plugin
Cleaning up Everything
Loading "skip-broken" plugin
fedora-7-test-debug       100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================|  52 kB    00:00     
livna-debug               100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================|  39 kB    00:00     
koji-f8-builds            100% |=========================| 1.1 kB    00:00     
primary.xml.gz            100% |=========================| 3.0 MB    00:10     
koji-f8-bu: ################################################## 11543/11543
fedora-7-updates          100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 2.2 MB    00:05     
fedora-7-test             100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 286 kB    00:01     
fedora-7-debug            100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================| 837 kB    00:00     
fedora-devel              100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 6.5 MB    00:15     
livna                     100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 113 kB    00:00     
fedora-7-updates-debug    100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================| 393 kB    00:01     
fedora-devel-debug        100% |=========================| 1.9 kB    00:00     
primary.sqlite.bz2        100% |=========================| 1.2 MB    00:03     
local                     100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================|  15 kB    00:00     
local     : ################################################## 33/33
fedora-7                  100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 4.7 MB    00:00     
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package perl-DBD-MySQL.x86_64 0:4.005-2.fc8.1 set to be updated
---> Package perl-Config-IniFiles.noarch 0:2.39-5.fc8.1 set to be updated
---> Package vino.x86_64 0:2.20.1-1.fc8 set to be updated
---> Package system-config-users.noarch 0:1.2.71-1.fc8 set to be updated
---> Package perl-libs.x86_64 4:5.8.8-28.fc8.3 set to be updated
---> Package GConf2-gtk.x86_64 0:2.20.1-1.fc8 set to be updated
---> Package perl-ExtUtils-Embed.x86_64 0:1.26-28.fc8.3 set to be updated
---> Package perl-Test-Simple.x86_64 0:0.62-28.fc8.3 set to be updated
---> Package gnome-system-monitor.x86_64 0:2.20.1-1.fc8 set to be updated
---> Package libvorbis.x86_64 1:1.2.0-1.fc8 set to be updated
---> Package evolution-data-server.x86_64 0:1.12.1-1.fc8 set to be updated
---> Package policycoreutils.x86_64 0:2.0.31-1.fc8 set to be updated
---> Package e2fsprogs.x86_64 0:1.40.2-9.fc8 set to be updated
---> Package e2fsprogs-libs.x86_64 0:1.40.2-9.fc8 set to be updated
---> Package control-center-filesystem.x86_64 1:2.20.1-1.fc8 set to be updated
---> Package libgpg-error.x86_64 0:1.5-6 set to be updated
---> Package perl-Date-Calc.x86_64 0:5.4-2.1 set to be updated
---> Package libbonobo.x86_64 0:2.20.1-1.fc8 set to be updated
---> Package gcalctool.x86_64 0:5.20.2-1.fc8 set to be updated
---> Package perl-DBD-SQLite.x86_64 0:1.12-2.fc8.1 set to be updated
---> Package perl.x86_64 4:5.8.8-28.fc8.3 set to be updated
--> Processing Dependency: db4-devel = 4.6.21 for package: perl
/usr/lib/python2.5/site-packages/yum/depsolve.py:439: UnicodeWarning: Unicode
equal comparison failed to convert both arguments to Unicode - interpreting them
as being unequal
  if pkg.pkgtup in self.rpmdb.simplePkgList(): # is it already installed?
---> Package samba.x86_64 0:3.0.26a-5.fc8 set to be updated
---> Package control-center.x86_64 1:2.20.1-1.fc8 set to be updated
---> Package GConf2.x86_64 0:2.20.1-1.fc8 set to be updated
---> Package samba-common.x86_64 0:3.0.26a-5.fc8 set to be updated
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.30-28.fc8.3 set to be updated
---> Package perl-Test-Harness.x86_64 0:2.56-28.fc8.3 set to be updated
---> Package at-spi.x86_64 0:1.20.1-1.fc8 set to be updated
---> Package libsmbclient.x86_64 0:3.0.26a-5.fc8 set to be updated
---> Package perl-devel.x86_64 4:5.8.8-28.fc8.3 set to be updated
---> Package gail.x86_64 0:1.20.1-1.fc8 set to be updated
---> Package perl-Convert-ASN1.noarch 0:0.21-2.fc8.1 set to be updated
---> Package system-config-date.noarch 0:1.9.14-1.fc8 set to be updated
---> Package samba-client.x86_64 0:3.0.26a-5.fc8 set to be updated
---> Package evolution.x86_64 0:2.12.1-1.fc8 set to be updated
---> Package kudzu.x86_64 0:1.2.79-1 set to be updated
---> Package system-config-services.noarch 0:0.9.17-1.fc8 set to be updated
--> Running transaction check
---> Package db4-devel.x86_64 0:4.6.21-1.fc8 set to be updated
--> Processing Dependency: libdb_cxx-4.6.so()(64bit) for package: db4-devel
--> Running transaction check
---> Package db4-cxx.x86_64 0:4.6.21-1.fc8 set to be updated
filelists.sqlite.bz2      100% |=========================| 437 kB    00:01     
filelists.xml.gz          100% |=========================|  10 MB    00:25     
filelists.sqlite.bz2      100% |=========================| 1.6 MB    00:04     
filelists.sqlite.bz2      100% |=========================| 812 kB    00:02     
filelists.sqlite.bz2      100% |=========================| 2.4 MB    00:00     
filelists.sqlite.bz2      100% |=========================|  10 MB    00:23     
filelists.sqlite.bz2      100% |=========================|  63 kB    00:00     
filelists.sqlite.bz2      100% |=========================| 4.7 MB    00:10     
filelists.sqlite.bz2      100% |=========================| 4.4 MB    00:11     
filelists.sqlite.bz2      100% |=========================| 107 kB    00:00     
filelists.xml.gz          100% |=========================|  87 kB    00:00     
filelists.sqlite.bz2      100% |=========================| 7.6 MB    00:00     
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 GConf2                  x86_64     2.20.1-1.fc8     koji-f8-builds    1.6 M
 GConf2-gtk              x86_64     2.20.1-1.fc8     koji-f8-builds     18 k
 at-spi                  x86_64     1.20.1-1.fc8     koji-f8-builds    243 k
 control-center          x86_64     1:2.20.1-1.fc8   koji-f8-builds    2.9 M
 control-center-filesystem  x86_64     1:2.20.1-1.fc8   koji-f8-builds     33 k
 e2fsprogs               x86_64     1.40.2-9.fc8     koji-f8-builds    1.0 M
 e2fsprogs-libs          x86_64     1.40.2-9.fc8     koji-f8-builds    134 k
 evolution               x86_64     2.12.1-1.fc8     koji-f8-builds     12 M
 evolution-data-server   x86_64     1.12.1-1.fc8     koji-f8-builds    3.7 M
 gail                    x86_64     1.20.1-1.fc8     koji-f8-builds    290 k
 gcalctool               x86_64     5.20.2-1.fc8     koji-f8-builds    1.2 M
 gnome-system-monitor    x86_64     2.20.1-1.fc8     koji-f8-builds    3.1 M
 kudzu                   x86_64     1.2.79-1         koji-f8-builds    208 k
 libbonobo               x86_64     2.20.1-1.fc8     koji-f8-builds    489 k
 libgpg-error            x86_64     1.5-6            koji-f8-builds     62 k
 libsmbclient            x86_64     3.0.26a-5.fc8    koji-f8-builds    904 k
 libvorbis               x86_64     1:1.2.0-1.fc8    koji-f8-builds    208 k
 perl                    x86_64     4:5.8.8-28.fc8.3  koji-f8-builds     11 M
 perl-Config-IniFiles    noarch     2.39-5.fc8.1     koji-f8-builds     45 k
 perl-Convert-ASN1       noarch     0.21-2.fc8.1     koji-f8-builds     42 k
 perl-DBD-MySQL          x86_64     4.005-2.fc8.1    koji-f8-builds    142 k
 perl-DBD-SQLite         x86_64     1.12-2.fc8.1     koji-f8-builds     49 k
 perl-Date-Calc          x86_64     5.4-2.1          koji-f8-builds    269 k
 perl-ExtUtils-Embed     x86_64     1.26-28.fc8.3    koji-f8-builds     34 k
 perl-ExtUtils-MakeMaker  x86_64     6.30-28.fc8.3    koji-f8-builds    288 k
 perl-Test-Harness       x86_64     2.56-28.fc8.3    koji-f8-builds     78 k
 perl-Test-Simple        x86_64     0.62-28.fc8.3    koji-f8-builds    109 k
 perl-devel              x86_64     4:5.8.8-28.fc8.3  koji-f8-builds    384 k
 perl-libs               x86_64     4:5.8.8-28.fc8.3  koji-f8-builds    558 k
 policycoreutils         x86_64     2.0.31-1.fc8     koji-f8-builds    948 k
 samba                   x86_64     3.0.26a-5.fc8    koji-f8-builds    2.9 M
 samba-client            x86_64     3.0.26a-5.fc8    koji-f8-builds    4.5 M
 samba-common            x86_64     3.0.26a-5.fc8    koji-f8-builds    7.3 M
 system-config-date      noarch     1.9.14-1.fc8     koji-f8-builds    1.1 M
 system-config-services  noarch     0.9.17-1.fc8     koji-f8-builds    190 k
 system-config-users     noarch     1.2.71-1.fc8     koji-f8-builds    397 k
 vino                    x86_64     2.20.1-1.fc8     koji-f8-builds    398 k
Installing for dependencies:
 db4-cxx                 x86_64     4.6.21-1.fc8     fedora-devel      607 k
 db4-devel               x86_64     4.6.21-1.fc8     fedora-devel      2.5 M

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update      37 Package(s)         
Remove       0 Package(s)         

Version-Release number of selected component (if applicable):

$ rpm -q rpm perl db4 yum
rpm-4.4.2.2-3.fc8.x86_64
perl-4:5.8.8-28.fc8.2.x86_64
db4-4.6.21-1.fc8.x86_64
yum-3.2.7-1.fc8.noarch
Comment 1 Seth Vidal 2007-12-06 22:22:18 EST
What is in your rpmdb that is not unicode or not convertable to unicode?
Comment 2 Nicolas Mailhot 2007-12-08 05:25:59 EST
(In reply to comment #1)
> What is in your rpmdb that is not unicode or not convertable to unicode?

How does one check this?
Comment 3 Seth Vidal 2008-03-12 10:57:41 EDT
Nevermind - I think this had more to do with the input. Can you check this issue
on yum 3.2.12 from rawhide? Or let me know how I can go about duplicating it?

thanks
Comment 4 Nicolas Mailhot 2008-04-19 09:01:14 EDT
I haven't seen it lately so something may have fixed it. Closing for now