Bug 335161

Summary: multilib file conflicts in gnokii
Product: [Fedora] Fedora Reporter: John Poelstra <poelstra>
Component: gnokiiAssignee: Linus Walleij <triad>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: rawhideCC: bnocera, bugs.michael, ffesti, james.antill, katzj, notting, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-30 00:58:13 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235703    
Attachments:
Description Flags
error messages
none
install log none

Description John Poelstra 2007-10-16 15:36:12 EDT
Description of problem:
`yum update` has trouble updating a number packages.  Possibly because one arch
is getting updated and one is not?

Version-Release number of selected component (if applicable):
# rpm -qa | grep yum
yum-metadata-parser-1.1.2-1.fc8
yum-updatesd-0.7-1.fc8
yum-3.2.7-1.fc8
yum-refresh-updatesd-1.1.7-1.fc8


How reproducible:
every time

See log file which contains details on all the packages that failed to update
today (system was current up to yesterday).
Comment 1 John Poelstra 2007-10-16 15:36:12 EDT
Created attachment 229171 [details]
error messages
Comment 2 Jeremy Katz 2007-10-16 15:57:29 EDT
What's the output of 'rpm -q --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}"
GConf2' and what command exactly are you using to update?
Comment 3 John Poelstra 2007-10-16 16:07:15 EDT
GConf2-2.20.0-2.fc8.x86_64
GConf2-2.20.0-2.fc8.i386

`yum -y update`
Comment 4 John Poelstra 2007-10-22 22:39:34 EDT
Created attachment 234691 [details]
install log
Comment 5 John Poelstra 2007-10-22 22:40:28 EDT
same problems installing taskjuggler--see log in comment#4
Comment 6 John Poelstra 2007-10-22 22:41:39 EDT
adding to F8 blocker on the basis that simple package installation and 
upgrades should work
Comment 7 Jesse Keating 2007-10-22 22:56:26 EDT
This is a multilib conflict in gnokii.
Comment 8 Jeremy Katz 2007-10-23 17:31:05 EDT
The Makefile in gnokii's po subdir is trying to be too smart and leading to
regenerated po files with different timestamps.
Comment 9 Linus Walleij 2007-10-23 17:59:05 EDT
*** Bug 228360 has been marked as a duplicate of this bug. ***
Comment 10 Linus Walleij 2007-10-23 17:59:44 EDT
*** Bug 341291 has been marked as a duplicate of this bug. ***
Comment 11 Linus Walleij 2007-10-23 18:06:36 EDT
I just don't get anywhere with this until I can set up some virtual
machine to do the testing, I don't have an x86_64 host, sadly. :-/
Anyone who likes to step in and patch the package, feel free to do so.

Bastien, can you look at this?
Comment 12 Bastien Nocera 2007-10-23 18:45:57 EDT
(In reply to comment #8)
> The Makefile in gnokii's po subdir is trying to be too smart and leading to
> regenerated po files with different timestamps.

And different versions of the .po file are causing problems with all those other
programs? I don't see gnokii being mentioned anywhere in the original bug log.
Seriously crappy bug. Went from a GConf2/yum bug to gnokii.

Anyway, gnokii doesn't do anything fancy to generate its messages file. The
Makefile are bog standard gettext supplied. If the generated files are
different, then it's msgfmt making them different.

I'll look into.
Comment 13 Jeremy Katz 2007-10-23 20:34:33 EDT
(In reply to comment #11)
> I just don't get anywhere with this until I can set up some virtual
> machine to do the testing, I don't have an x86_64 host, sadly. :-/
> Anyone who likes to step in and patch the package, feel free to do so.
> 
> Bastien, can you look at this?

Note that you don't really need an x86_64 machine to look at it.  Finding the
conflicts can be done with http://katzj.fedorapeople.org/multilib-cmp.py. 

(In reply to comment #12)
> (In reply to comment #8)
> > The Makefile in gnokii's po subdir is trying to be too smart and leading to
> > regenerated po files with different timestamps.
> 
> And different versions of the .po file are causing problems with all those other
> programs? I don't see gnokii being mentioned anywhere in the original bug log.
> Seriously crappy bug. Went from a GConf2/yum bug to gnokii.

No argument from me on the bug history -- I really looked at it for the first
time this afternoon

> Anyway, gnokii doesn't do anything fancy to generate its messages file. The
> Makefile are bog standard gettext supplied. If the generated files are
> different, then it's msgfmt making them different.

The po files end up different because they're being regenerated when they really
shouldn't be at build time.  I'm not quite sure why the update-gnokii.pot rule
is getting run and then the remove-potcdate.sed stuff is also pretty strange

> I'll look into.

Hopefully I'll spend a little more time tonight and it'll pop out at me, but I
wanted to be sure to get the current status of what was going on into the bug
before I went home.
Comment 14 Jeremy Katz 2007-10-23 23:03:37 EDT
Committed a bit of a quick fix to CVS.

The problem definitely seems to stem from the remove-potcdate.sed and updating
of the po file bits, so I've just removed them for now; the cost is that the po
files don't get msgmerged with the pot before we create the mo files, but that
actually isn't a problem and most gettext-based Makefiles don't set that up.
Comment 15 Linus Walleij 2007-10-24 05:21:25 EDT
Thanks Jeremy, I saw you tagged it as well so I assume this is being
built and pushed too?
Comment 16 Jeremy Katz 2007-10-24 07:52:57 EDT
Yep (although apparently my network connection fell over and so it didn't get
tagged for today's rawhide)
Comment 17 Jesse Keating 2007-10-25 10:12:49 EDT
This isn't fixed.  There is still a pile of conflicts in
/usr/share/local/*/LC_MESSAGES/gnokii.mo
Comment 18 Jeremy Katz 2007-10-28 16:21:52 EDT
Bah, fixed better 
Comment 19 John Poelstra 2007-10-30 00:58:13 EDT
no problems installing TaskJuggler now on x86_64 from latest updates.