Bug 336761

Summary: Loader dialog does not properly retry after failing to fetch a kickstart
Product: [Fedora] Fedora Reporter: Will Woods <wwoods>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-19 10:41:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description Will Woods 2007-10-17 17:40:00 EDT
In testing bug 334881, I tried to run a kickstart install with this on the
commandline: 
  ks=nfs://hank:/mnt/qa/scratch/wwoods/f8-default-ks.cfg

loader fails to fetch this file, and gives me the "Error downloading kickstart
file" dialog to allow me to fix the URI. I corrected it to:
  nfs:hank:/mnt/qa/scratch/wwoods/f8-default-ks.cfg
which *should* work - it works if I pass this on the boot commandline - but
loader doesn't retry the mount, so it doesn't work.

Here are the relevant log messages:

INFO    : doing kickstart... setting it up
INFO    : reverse name lookup worked
INFO    : url is //hank:/mnt/qa/scratch/wwoods/f8-default-ks.cfg
INFO    : file location: nfs:////hank:/mnt/qa/scratch/wwoods/f8-default-ks.cfg
ERROR   : failed to mount nfs source
[here I fix the parameter and hit OK]
ERROR   : getFileFromNfs: no client IP information
[the above message is emitted every time I hit OK]
Comment 1 Chris Lumens 2007-10-19 10:41:45 EDT
This will be fixed in the next build of anaconda.