Bug 334881 - anaconda does not use kickstart file through nfs
anaconda does not use kickstart file through nfs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 13:33 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 16:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-10-16 13:33:17 EDT
Description of problem:

Doing PXE/kickstart install. ks file is on nfs server.  Anaconda logs indicate:

file location: nfs://saga:/export/data1/ks/rawhide-desktop.cfg
setting up kickstart


but then it is prompting me for language, keyboard, install location, etc.

Version-Release number of selected component (if applicable):
anaconda-11.3.0.39-2
Comment 1 Chris Lumens 2007-10-17 16:41:59 EDT
The correct syntax here is ks=nfs:saga:/export/data1/ks/rawhide-desktop.cfg.

If it's failing to download the kickstart file, you should at least be getting
the dialog box prompting you to enter a new location.  Are you not getting that
dialog box?
Comment 2 Orion Poplawski 2007-10-18 11:41:39 EDT
Sorry, my bad.  Somehow the rawhide-desktop.cfg was actually a directory and not
a file on my server and I didn't notice until I poked around further.

nfs found it, but since it didn't contain anything nothing happened.  http
returns an error so it prompted for a new file location (which is what spurred
me to check further).

Note You need to log in before you can comment on or make changes to this bug.