Bug 3387

Summary: Red Hat does't start after Accelerated X 5.0 install
Product: [Retired] Red Hat Linux Reporter: fleck_work
Component: SysVinitAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-06-11 18:35:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description fleck_work 1999-06-10 14:35:12 UTC
Here I come with more bugs to report...

OK.  This is the way it worked.  I installed Red Hat 6.0
and then Accelerated X 5.0.  The first time it was not
a Full install.  I cannot remember if it was a Minimal
or what, I just know it wasn't a full install.  Something
happened with my modem and sound, so I erased the whole
thing and did a complete reinstall.  This time I have
installed Accelerated X 5.0 "FULL" and the updated to
5.0.1...  I typed "reboot".  Uh-oh!  When the Red Hat
init was running and the [ OK ] remars were scrolling
up, it got to this initiaton of X11 Font Server or
something of the sort.  This of course did not work
and the system comes to a complete halt.  This of course
has to be the "FULL" install of Accelerated X 5! Yikes!
Now I gotta go home today and boot up a mini-distro
so that I can find the init file which does that evil
stuff and kill that section.  This of course is probably
not an XFree86 problem, so I put it down in the SysVinit
since I don't know much about the whole init process of
Linux (except for how files in /etc/rc.d work) and
much less Red Hat Linux...

I should have my sound/modem problem bug report up
next...  it has to do with sndconfig and stuff...

------- Additional Comments From   06/11/99 10:18 -------
as a follow-up to this, i was able to install Enoch,
(you can look at www.swcp.com/~drobbins/enoch for info)
a small, efficient, and useful tiny Linux distro on a
partition on my system.  I was then able to find the file
which someone told me to look at (Thanks to #LinuxHelp
on EFNet!) which was /etc/rc.d/init.d/xfs or something of
taht sort.  Anyway, I moved the file to /xfs.old and removed
executable marks, just to make sure that I had a backup
and that it would, by no means, execute.  The system booted
perfectly and I am running Red Hat 6.0 with Accelerated X 5.0
and it works!  I had to take some font directories from
/etc/X11/fs/config (is that the right place?  im at work right now)
and put them in /etc/Xaccel.ini so that I could get the full
ammount of fonts, however, this was easy and all I had to add
were a few characters here and there.   So it is all perfect
now.  However, if you want to make it secure, just make sure
that the Accelerated X directory doesn't exist in the xfs
script, or just make sure that /etc/Xaccel.ini does't exist!
That SHOULD fix the problems...

Comment 1 Preston Brown 1999-06-11 18:34:59 UTC
This sounds more like a problem with accelerated X stomping all over
our own X install than with a problem with our own files.  Unless you
can provide better details as to how the interaction between
Accelerated X and our own X was broken, I am going to have to close
this, as it seems like installing Accelerated X broke things that
worked fine before.

Please reopen the bug if you have details as to why the xfs init
script no longer worked with Accelerated X.