This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 350051

Summary: need a locale for Tibetan (bo)
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: cfynn, drepper.fsp, eng-i18n-bugs, mgarski, triage
Target Milestone: ---Keywords: i18n, MoveUpstream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: bzcl34nup
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-14 22:59:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 167536    

Description Jens Petersen 2007-10-24 01:52:14 EDT
glibc does not currently have a locale file for Tibetan.
This makes it hard to run programs in the native language.

This bug is to track the addition of the locale.

Is there a process for getting a new locale added upstream?
Comment 1 Jens Petersen 2007-10-24 01:54:10 EDT
http://sources.redhat.com/bugzilla/show_bug.cgi?id=368 for dz_BT
(Bhutanese) which is a close language to Tibetan may be a good reference.
Comment 2 Jakub Jelinek 2007-10-24 07:24:29 EDT
A bugreport like this is useless without the actual patch to add the locale.
Only over that we can discuss if it can be added and who will be the maintainer
of that locale.
Comment 3 Jens Petersen 2007-10-24 20:09:50 EDT
Chris, would you be able to assist with the Tibetan locale?

I am still waiting to hear from Ngodrup...
Comment 4 Chris Fynn 2007-10-25 00:30:17 EDT
Hi Jens

I'd be happy to *assist* with this.

A Tibetan (bo) locale would pretty much the same as a Dzongkgka (dz) locale. 

One important difference is that localised nmes for days of the week should be
shifted back by one. The names (and abbreviations) for the days of the week are
the same words in Tibetan & Dzongkha - but in Dzongkha they are one day ahead -
e.g. གཟའ་ཉི་མ་ [ \u0F42\u0F5F\u0F60\u0F0B\u0F49\u0F72\u0F0B\u0F58\u0F0B ] is the
Dzongkha name for Saturday but the Tibetan name for Sunday.

Tibetan collation is a true sub-set of Dzongkha collation - so LC_COLLATE
element from dz_BT locale should work fine for Tibetan locale. 

Country specific things like currency, time zone, etc could be    
taken zh_CN for a bo_CN locale; and from hi_IN or en_IN for a bo_IN locale.

There is now also considerable locale information for Tibetan in CLDR
<http://unicode.org/cldr/apps/survey?s=fdL03y20m_ux19FZiVdzDSAfSEg,&_=bo>

Probably the easiest thing to do is take the dz_BT locale and make changes
wherever there is a difference for Tibetan.

- Chris  

- Chris 
Comment 5 Chris Fynn 2007-10-25 00:48:01 EDT
One other thought..

In China there is apparently a localised version of Red Flag Linux including
Tibetan. It must have a bo_CN locale. The data in that would be official since
that project was supported by the Govt. of China and Tibet University in Lhasa. 

That distribution may use the Chinese GB 18030 based encoding for pre-composed
Tibetan rather than Unicode - but it is easy enough to convert from that
character encoding to Unicode. 

I also don't know where to find the CVS or SVN for Red Flag Linux - and if
everything is in Chinese as I suspect it might be it would be difficult for me
to locate the relevant file since I don't read Chinese.



 

 

Comment 6 Ulrich Drepper 2007-11-06 13:27:25 EST
I've added bo_CN and bo_IN locales upstream.  I know nothing about the language
so somebody will have to check the files.
Comment 8 Chris Fynn 2007-11-15 01:04:15 EST
Will try to do this weekend - I'll first need to convert all the "<U0Fnn>" to
Unicode to make it humanly readable.

-  Chris.   
Comment 9 Ulrich Drepper 2007-11-15 01:11:04 EST
(In reply to comment #8)
> Will try to do this weekend - I'll first need to convert all the "<U0Fnn>" to
> Unicode to make it humanly readable.

In the glibc sources there is a program called show-ucs-data.

Comment 10 Jens Petersen 2008-01-03 02:19:26 EST
Thanks for all the help on this. :)

Changing to MODIFIED since glibc-2.7.90 in rawhide (Fedora devel)
now contains the locale.

Would still greatly appreciate it if you have time to review them, Chris.
Comment 11 Bug Zapper 2008-04-04 10:15:25 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 12 Jens Petersen 2008-04-14 22:59:39 EDT
I see /usr/share/locale/{bo_CN,bi_IN} in current pre-F9.

I guess eventually it would be nice to have translations too.
Chris, do you know anyone in the community who might be willing
to contribute them?