Bug 354981

Summary: Problem with sound after using the new alsa-kernel
Product: [Fedora] Fedora Reporter: Espen Stefansen <libbe>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: maximlevitsky, pawsa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.23.1-49.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-09 18:38:10 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
scsconfig.log
none
/proc/asound/Intel/codec#0 none

Description Espen Stefansen 2007-10-26 20:17:41 EDT
Description of problem:
If i play some music or watch a video and i change the sound, it doesn't change
directly to the new volume, but goes silent and then the sound gradually changes
to the new volume. It takes about 5 seconds.

In s-c-soundcard it finds the soundcard, but i can't hear any sounds.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-37.fc8
kernel-2.6.23.1-36.fc8

Everything else is latest rawhide

How reproducible:
Every time

Steps to Reproduce:
1. Change sound
2. Sound mutes and "goes" slowly to the new volume
3.
  
Actual results:
Mutes, then it takes 5 seconds to get to the new volume-level

Expected results:
Should change immediately

Additional info:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
Comment 1 Dave Jones 2007-10-26 20:32:52 EDT
hmm, but everything was ok in -35 ?
Comment 2 Espen Stefansen 2007-10-26 20:39:20 EDT
Yes, it was.
Comment 3 Espen Stefansen 2007-10-27 05:39:18 EDT
More strange things are happening with my sound now. If i press the
'mute'-button on my laptop, it mutes as it should. But if Rhythmbox finishes a
song when the sound is muted, the sound is set to 0% from the next song. But
sometimes the music is actually playing when a new song comes on, even though
the sound is supposed to be muted! In addition Rhythmbox now crashes on exit
regularly.

Seems like there are some incompatibilities with how to change sound-levels than
before.
Comment 4 Espen Stefansen 2007-10-29 09:31:42 EDT
Ok... now i've updated to the new alsa-rpms. And things work a little bit
better. Can now turn mute on or off, but the sound is "lower" and then goes
gradually back to normal sound after a few seconds.

I've got difficulty explaining all of this, but i'll try. When changing the
master volume, it "goes" love then slowly increases to the correct volume. 
If master-volume is at about 90%, but the sound in rhythmbox is about 20%. It
takes about 5 seconds to get the correct volume.
If master-volume is at about 20%, but the sound in rhythmbox is 20%. It takes at
least 30 seconds to get the correct volume, that includes 10 seconds in the
beginning when you can't hear anything.

Here's another example:
If the sound in rhytmbox is set to 100% and the master is set 100%. I've lowered
the front-sound it won't "blow up" my built-in speakers. If i then lower the
master sound, the sound decreases but after a while the sound goes back to the
same level as 100% level, but master says its lower than 100%.

So it seems it has some problems with keeping volume-levels. Hope this helps to
understand my problem. This is a serious problem for me!
Comment 5 Espen Stefansen 2007-10-29 09:33:07 EDT
Created attachment 241841 [details]
scsconfig.log

Here's my scsconfig.log. Maybe you find something useful there.
Comment 6 Chuck Ebbert 2007-10-29 14:11:40 EDT
Dell Latitude D630
STAC92XX codec

There is a whole set of fixes for the STAC92XX codec pending in upstream ALSA,
including this one:

hda-codec - Fix conflict of Master volume in STAC92xx codec
http://hg.alsa-project.org/alsa-kernel/rev/e2b50ea6b7ed

This will probably fix it, and being in-sync with upstream would allow us to add
the update after F8 release.
Comment 7 Maxim Levitsky 2007-11-01 14:27:13 EDT
This won't fix it. I know, since the codec was detected. It only fixes cases 
when the driver didn't load.

Probably this isn't a bug, probably the new "Master Volume" which wasn't 
present before (right?) doesn't work on your hardware.

Please give me contents of /proc/asound/Intel/codec* so I can determine what 
sigmatel codec you have.

If I understand you right, the mixer control itself doesnt "drift", but rather 
the actual volume you hear, right?

Regards,
    Maxim Levitsky
Comment 8 Espen Stefansen 2007-11-01 19:32:34 EDT
Created attachment 246141 [details]
/proc/asound/Intel/codec#0
Comment 9 Espen Stefansen 2007-11-01 19:57:44 EDT
I'll try to explain this again. :)

Rhythmbox volume is at 20%, which is the soundlevel i want. no matter how i 
change the master volume, the volume doesn't change. BUT, when i change the 
master volume it goes silent then back to normal level, but it just takes time. 
The time it takes depends on what volume the master volume is at.

If i change master from any level to 95%, it takes about 1 second to change 
from total silence back to the same level as before.
If i change master from any level to 50%, it takes about 20 seconds to change 
from total silence back to the same level as before.
If i change master from any level to 95%, it takes about 50 seconds to change 
from total silence back to the same level as before.
And mute doesn't work, it just takes over a minute to go back to the same level 
as before.

So basically master-volume has no impact on the soundlevel.
Comment 10 Maxim Levitsky 2007-11-02 08:13:07 EDT
Thanks.

Do you have a physical volume slider on the system
(I mean real volume knob)

If you have it then it takes over the software volumeknob.
And thus just ignore the 'Master' Volume control.

If not, maybe STAC9205 you have, the last STAC that isn't yet tested to work
with 'Master Volume', doesn't work with it.

Do you have just the 'Master' and 'Capture' controls in the mixer?
Sound bogus to me.

Can you post output of amixer again?


Regards,
    Maxim Levitsky

Comment 11 Espen Stefansen 2007-11-02 08:27:46 EDT
This is a laptop, so i have a button for increase, decrease and mute the sound. 
But it doesn't matter if i use the buttons or if i use the mouse to click on 
the master-volume to change it.

The master-volume in the gnome-panel is set to 50%.

[espenas@itse68482 ~]$ amixer 
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 34953 [53%] [on]
  Front Right: Capture 34953 [53%] [on]
Comment 12 Maxim Levitsky 2007-11-02 09:01:03 EDT
You mean that those 'buttons' are just buttons which gets reported to 
userspace, and it sets the volume?

Strange, very strange.....

I don't understand why you got so few controls in the mixer.
why....

It feels like you don't have alsa 1.15, but the log indicate you have.
Maybe it is patched by redhat, in some way, but anyway very strange.

According to the logs,

you have:
1) HP-out
2) Mic-in

Do you have other analog inputs/outputs in the system?
Ddo you have internal speaker in the system?

Did you have different mixer controls 
in kernel-2.6.23.1-35?

Can you give me now
amixer contents

I see what can I do.

Comment 13 Maxim Levitsky 2007-11-02 09:15:34 EDT
I will download kernel-2.6.23.1-42.fc8.src.rpm to see what alsa is really 
there.

I suggest you test it too.
Or give me link to kernel-2.6.23.1-36

And it will be great to see kernel-2.6.23.1-35, is it possible to download
it somewhere.
Comment 14 Espen Stefansen 2007-11-02 09:48:09 EDT
You can find the kernels here:
kernel-2.6.23.1-36: http://koji.fedoraproject.org/koji/buildinfo?buildID=22426
kernel-2.6.23.1-35: http://koji.fedoraproject.org/koji/buildinfo?buildID=22273

I have a Dell D630 laptop, with internal speakers. You can take a look at the 
hardware here: http://smolt.fedoraproject.org/show?UUID=0303dea0-a961-4bba-b127-
d1f3ef7ee769
Comment 15 Espen Stefansen 2007-11-02 09:57:05 EDT
This is with kernel-2.6.23.1-35:
[espenas@itse68482 ~]$ amixer 
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
Comment 16 Espen Stefansen 2007-11-02 10:01:56 EDT
Another thing i noticed when using kernel-2.6.23.1-35, is that if i open gnome-
volume control, i only have the 'front'-volume under the playback-tab. And the 
buttons and the sound applet is using 'front'
In kernel-2.6.23.1-36 and above i have both front and master. And the buttons 
and the sound applet is instead using 'master'. If i use 'front' to change the 
sound, it works.

I hope this made sense... :)
Comment 17 Maxim Levitsky 2007-11-02 10:06:42 EDT
Give me please
'amixer contents'

and can you describe what controls you see in 
gnome-volume control

for kernel-2.6.23.1-36

Regards,
    Maxim Levitsky
Comment 18 Espen Stefansen 2007-11-02 10:20:50 EDT
[root@itse68482 ~]# cat amixer-contents-kernel-2.6.23.2-35
numid=0,iface=MIXER,name='Master Playback Switch'
  ; type=BOOLEAN,access=rw------,values=1
  : values=on
numid=0,iface=MIXER,name='Master Playback Volume'
  ; type=INTEGER,access=rw------,values=2,min=0,max=65536,step=1
  : values=65536,65536
numid=0,iface=MIXER,name='Capture Switch'
  ; type=BOOLEAN,access=rw------,values=1
  : values=on
numid=0,iface=MIXER,name='Capture Volume'
  ; type=INTEGER,access=rw------,values=2,min=0,max=65536,step=1
  : values=65536,65536

[root@itse68482 ~]# cat amixer-contents-kernel-2.6.23.2-36
numid=0,iface=MIXER,name='Master Playback Switch'
  ; type=BOOLEAN,access=rw------,values=1
  : values=on
numid=0,iface=MIXER,name='Master Playback Volume'
  ; type=INTEGER,access=rw------,values=2,min=0,max=65536,step=1
  : values=65536,65536
numid=0,iface=MIXER,name='Capture Switch'
  ; type=BOOLEAN,access=rw------,values=1
  : values=on
numid=0,iface=MIXER,name='Capture Volume'
  ; type=INTEGER,access=rw------,values=2,min=0,max=65536,step=1
  : values=34953,34953

[root@itse68482 ~]# diff -u amixer-contents-kernel-2.6.23.2-35 amixer-contents-
kernel-2.6.23.2-36 
--- amixer-contents-kernel-2.6.23.2-35  2007-11-02 15:11:57.000000000 +0100
+++ amixer-contents-kernel-2.6.23.2-36  2007-11-02 15:17:29.000000000 +0100
@@ -9,4 +9,4 @@
   : values=on
 numid=0,iface=MIXER,name='Capture Volume'
   ; type=INTEGER,access=rw------,values=2,min=0,max=65536,step=1
-  : values=65536,65536
+  : values=34953,34953

gnome-volume-control:
kernel-2.6.23.2-35: front
kernel-2.6.23.2-36: master and front
Comment 19 Pawel Salek 2007-11-05 11:20:20 EST
*** Bug 361051 has been marked as a duplicate of this bug. ***
Comment 20 Chuck Ebbert 2007-11-06 19:39:44 EST
Revert of the STAC codec volume control changes is in kernel 2.6.23.1-47. This
should fix the bug.
Comment 21 Espen Stefansen 2007-11-07 16:13:01 EST
In kernel-2.6.23.1-48.fc8 the sound works as it should. :)
Comment 22 Fedora Update System 2007-11-09 18:38:06 EST
kernel-2.6.23.1-49.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.