Bug 361051 - 2.6.23.1-42.fc8/snd_hda_intel sound volume drift
2.6.23.1-42.fc8/snd_hda_intel sound volume drift
Status: CLOSED DUPLICATE of bug 354981
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 18:12 EDT by Pawel Salek
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 11:20:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log created with 2.6.23.1-42.fc8 (49.84 KB, text/plain)
2007-10-31 19:20 EDT, Pawel Salek
no flags Details
Contents of /proc/asound/Intel/codec#[01] (5.04 KB, text/plain)
2007-11-06 03:05 EST, Pawel Salek
no flags Details

  None (edit)
Description Pawel Salek 2007-10-31 18:12:26 EDT
Description of problem:
When the Master volume is set to less than 100%, it start slowly drifting (time
scale 10-20s) back to 100% and the volume increases. The volume control applet
setting remains unchanged. When the volume applet widget is just touched, the
volume is reset back to the original value. "PCM" and "Front" settings do not drift.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-42.fc8
alsa-lib-1.0.15-1.fc8.x86_64

How reproducible:
Always. This must be some recent problem because it did not happen few days ago
and I track the updates closely every 1-3 days.
Comment 1 Chuck Ebbert 2007-10-31 18:20:05 EDT
What was the version of the previous kernel that worked?
Comment 2 Pawel Salek 2007-10-31 18:40:13 EDT
I see now it must have happen earlier: kernel-2.6.23.1-37.fc8 drifts as well.
kernel-2.6.23-0.214.rc8.git2.fc8 does NOT drift. I have to find now some kernels
in between.
Comment 3 Chuck Ebbert 2007-10-31 18:55:11 EDT
Please run the soundcard detection utility and go to the third tab and generate
a report, then attach it to this bugzilla.
Comment 4 Pawel Salek 2007-10-31 19:11:36 EDT
2.6.23.1-35.fc8 is ok, 2.6.23.1-36.fc8 isn't. I note that the latter presents a
"Master" Volume control widget while the former does not.
Comment 5 Pawel Salek 2007-10-31 19:20:58 EDT
Created attachment 244991 [details]
scsconfig.log created with 2.6.23.1-42.fc8
Comment 6 Maxim Levitsky 2007-11-05 10:38:13 EST
Please take a look at 
https://bugzilla.redhat.com/show_bug.cgi?id=354981

And also at 
http://mailman.alsa-project.org/pipermail/alsa-devel/2007-November/003817.html

We are discussing a similar bug there.
Comment 7 Pawel Salek 2007-11-05 11:20:19 EST
Looks like an identical bug to me.

*** This bug has been marked as a duplicate of 354981 ***
Comment 8 Maxim Levitsky 2007-11-05 16:57:52 EST
Since your report is a bit different, I want to suggest you to start
alsamixer in console using this command:

alsamixer -D hw:0

and change master volume here.
Does this work?

Comment 9 Pawel Salek 2007-11-05 17:39:15 EST
alsamixer -D hw:0 behaves identically as gnome-volume-control: when the master 
volume is reduced, the actual volume starts drifting up, but the position of the
control widget in alsa-mixer remains unchanged. Pressing <Up> or <Down> key
resets the actual volume to the level visualized by alsamixer - and then it
starts drifting again... Also as with g-v-c, values set for PCM and Front
channels stay fixed, no drift is observed.
Comment 10 Maxim Levitsky 2007-11-05 18:04:54 EST
Great.

It is probably hardware bug.
All I do is I set hardware control 'VolumeKnob'
probably it is broken on your stac
(Probably all STAC9205s have this bug, since windows driver doesn't
use it, and linux drivers wasn't using it till I added support for it)

I wait and see whenever I get more bug reports.
Meanwhile just ignore the 'Master' control. and use 'Front'
instead like you did before.

Best regards,
       Maxim Levitsky
Comment 11 Maxim Levitsky 2007-11-05 18:06:03 EST
Also you can use 'PCM' to lower the volume in software.
Comment 12 Pawel Salek 2007-11-05 18:16:28 EST
Thanks for tracking this down. Now, I need to figure out how to change the
binding in gnome-keybinding-properties of "Volume Up" action from controlling
the Master Volume to controlling the Front or PCM volumes. (but this is out of
the scope for this bug).
Comment 13 Chuck Ebbert 2007-11-05 18:22:36 EST
I can revert the commit that added the support for that control; we can see if
that helps.
Comment 14 Maxim Levitsky 2007-11-05 18:27:32 EST
It will 100% help, but I don't yet know whenever the VolumeKnob is broken on 
very few systems, or it is broken on all STAC9205 or maybe even in all 
STAC9204/54/55 codecs
Comment 15 Maxim Levitsky 2007-11-05 20:12:47 EST
Pawel Salek, can you give me contents of /proc/asound/Intel/codec*

I want to know what STAC codec exactly you have to track down what codecs 
don't have good VolumeKnob
Comment 16 Pawel Salek 2007-11-06 03:05:02 EST
Created attachment 248861 [details]
Contents of /proc/asound/Intel/codec#[01]

Contents attached. There are two codecs available. #0 is  SigmaTel STAC9205
(audio?), #1 is Conexant ID 2c06 (modem?)
Comment 17 Maxim Levitsky 2007-11-06 09:24:40 EST
Thank you very much.
The Conexant ID 2c06 is  modem, and it is unrelated.

You have the same STAC9205 as in 354981.

Best regards,
    Maxim Levitsky

Note You need to log in before you can comment on or make changes to this bug.