Bug 375721

Summary: wpa_supplicant will not start at boot time in F8 - but will start manually
Product: [Fedora] Fedora Reporter: Mike Cohler <mdc1>
Component: wpa_supplicantAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 8CC: bernd.bartmann, dr, mellomann01, razvan.sandu
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-13 11:43:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Image showing the failure message during boot
none
wpa_supplicant log file showing dbus problems none

Description Mike Cohler 2007-11-11 06:01:15 EST
Description of problem:With "chkconfig wpa_supplicant on" the daemon fails to
start at boot time.


Version-Release number of selected component (if
applicable):wpa_supplicant-0.5.7-15.fc8


How reproducible:Every time


Steps to Reproduce:
1. Do chkconfig wpa_supplicant on
2. Re-boot
3.
  
Actual results:During boot wpa_supplicant daemon fails to start (see attached
screen image to be attached shortly)


Expected results:wpa_supplicant daemon should start during boot process.


Additional info:There are not messages of relevance in /var/log/messages
The file /var/log/wpa_supplicant does have lines such as:
CTRL-EVENT-TERMINATING - signal 15 received
Could not acquire the system bus.

I will attach this file shortly.

Note that if chkconfig wpa_supplicant off and then the machine is booted - no
failed messages appear during boot, and running "service wpa_supplicant start"
manually once the computer is booted does let the daemon start up correctly and
rapidly, and then dhclient will get an ip address. The connection is set up to
connect to a home AP using WPA2/psk and works fine when started manually.

The system is a clean install F8, with all updates current, and running kernel
2.6.23.1-49.fc8
Comment 1 Mike Cohler 2007-11-11 06:02:37 EST
Created attachment 254371 [details]
Image showing the failure message during boot

Note the dbus error during this boot sequence.
Comment 2 Mike Cohler 2007-11-11 06:04:28 EST
Created attachment 254391 [details]
wpa_supplicant log file showing dbus problems
Comment 3 Mike Cohler 2007-11-11 14:46:55 EST
Looking at the screen image during boot from #1 is it possible that there is a
space missing in the sequence -Dwextdbus... i.e. is it
that in a config file (but where?) it should instead be -Dwext dbus.... ?
Comment 4 Bernd Bartmann 2007-11-11 15:20:13 EST
I'm seeing similar issues with wpa_supplicant on F8:

[root@defiant wpa_supplicant]# service wpa_supplicant start
wpa_supplicant wird gestartet: /etc/wpa_supplicant/wpa_supplicant.conf, ,
dbus_bus_request_name[dbus]: Resource temporarily unavailable
Failed to initialize wpa_supplicant

/etc/wpa_supplicant/wpa_supplicant.conf contains:
 
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

Comment 5 Mike Cohler 2007-11-11 16:31:30 EST
The odd thing is that once I am logged in (as a user) I can open a terminal
window and become root - at that point service wpa_supplicant start does work -
and I can then do dhclient eth1 and it gives a nice stable wireless connection.
So this is different from your situation where you can't start the supplicant
from the command line. However you are also seeing a dbus problem so I guess it
is related but it would be nice to know exactly where the problem lies.
Comment 6 Ronny Fischer 2007-11-13 04:14:52 EST
I can confirm this bug. The dbus interface starts after network and
wpa_supplicant. I guess the wpa_supplicant needs dbus in case to register itself
for the network interface.

A manual restart is necessary atm. In my case  I need to restart the service
network, too to get my wireless connection work.

Comment 7 Kevin P. 2007-11-13 06:26:24 EST

(In reply to comment #4)
> I'm seeing similar issues with wpa_supplicant on F8:
> 
> [root@defiant wpa_supplicant]# service wpa_supplicant start
> wpa_supplicant wird gestartet: /etc/wpa_supplicant/wpa_supplicant.conf, ,
> dbus_bus_request_name[dbus]: Resource temporarily unavailable
> Failed to initialize wpa_supplicant
> 
> /etc/wpa_supplicant/wpa_supplicant.conf contains:
>  
> ctrl_interface=/var/run/wpa_supplicant
> ctrl_interface_group=wheel
> 
> 
i have the same problem.. no manual restart of the service is possible :( :( 
Comment 8 Mike Cohler 2007-11-13 08:50:08 EST
I had a thought that I will test when I get home this evening (my laptop is not
with me at the moment).

In the file /etc/init.d/wpa_supplicant

Note the lines:

start() {
        echo -n $"Starting $prog: $conf, $INTERFACES, $DRIVERS"
        daemon $prog -c $conf $INTERFACES $DRIVERS -B -u -f
        retval=$?
        echo
        [ $retval -eq 0 ] && touch $lockfile
        return $retval
}

It looks to me that the daemon line has an error in it. So instead of 
        daemon $prog -c $conf $INTERFACES $DRIVERS -B -u -f
it should be
        daemon $prog -c$conf $INTERFACES $DRIVERS -B -u -f

i.e. remove the space between -c and $conf since the manual startup would call
for a command line (from man wpa_supplicant) that would read:

wpa_supplicant -c/etc/wpa_supplicant.conf -iwlan0 -d

In this example there is also no space between the -c and /etc/wpa.....

I will test this later today and report back If it works.  I also notice that
this error seems to be present in f7 since I have checked the machine I am
currently running with f7 and this script also has this problem.

If so then it is presumably an easy fix to put into an update for wpa_supplicant?
Comment 9 Kevin P. 2007-11-13 09:27:54 EST
i have tested it a minute ago...unfortunately, no success... :(
Comment 10 Mike Cohler 2007-11-13 09:37:30 EST
OK - I will test this on my machine later today. I wonder if the underlying
problem is something to do with a script error, or if it is due to a startup
timing error - I will look into the startup sequence when I get some time - I
note that in the initscripts wpa_supplicant starts at S88 - I wonder if this
might need changing?

Is there anything it depends on which is started after that?
Comment 11 Mike Cohler 2007-11-13 09:39:16 EST
One difference between your situation and mine is that I can do a manual start
of the daemon after logging in whereas it seems you can't - so perhaps in my
case this fix may work - frustrating that I am away from the machine with f8 today!
Comment 12 Dan Williams 2007-11-13 11:43:34 EST

*** This bug has been marked as a duplicate of 244029 ***
Comment 13 Răzvan Sandu 2007-11-15 01:39:09 EST
*** Bug 337001 has been marked as a duplicate of this bug. ***