This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 337001 (linwille@redhat.com) - wpa_supplicant reports a missing file at initialization on Dell Inspiron 1520
Summary: wpa_supplicant reports a missing file at initialization on Dell Inspiron 1520
Status: CLOSED DUPLICATE of bug 244029
Alias: linwille@redhat.com
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL: http://www.linlap.com/wiki/Dell+Inspi...
Whiteboard:
Keywords:
Depends On:
Blocks: 328451
TreeView+ depends on / blocked
 
Reported: 2007-10-18 03:05 UTC by Răzvan Sandu
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 06:39:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Răzvan Sandu 2007-10-18 03:05:06 UTC
Hello,

Description of problem:

The wireless device on the Dell Inspiron 1520 works (from the kernel point of
view) - please see bug #328451.

The wireless interface wlan0 doesn't show up in System ->
Administration -> Network, not even when the interface is up and actually
running. As a consequence, it cannot be controlled easily, set up for DHCP, etc.

After the latest online updates: at system boot, wpa_supplicant fails, reporting
a missing file in /etc/wpa_supplicant... The same error is reported when one
attempts to manually start the wlan0 interface using the wlassistant utility -
wireless network is found, but wlasisstant cannot connect.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.3.svn2970.fc8
wpa_supplicant-0.5.7-10.fc8


How reproducible:
Always.

Steps to Reproduce:
Please see bug #328451.
  
Actual results:
Wireless interface wlan0 cannot be controlled by Network Manager, like any
regular interface; after the latest online updates, it cannot be started by
wlassistant as well, apparently because of a missing file under
/etc/wpa_supplicant (wpa_supplicant initialization failure).

Expected results:
Wireless interface should be controlled like any other interface, in both text
and X mode - start at boot, take address through DHCP or by static
configuration, etc.

Additional info:
http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132
http://forum.notebookreview.com/showthread.php?t=152717
http://www.linlap.com/wiki/Dell+Inspiron+1520

Thanks,
Răzvan

Comment 1 Răzvan Sandu 2007-10-18 08:58:42 UTC
Hello,

Analyzing the list of open bugs on wpa_supplicant as of October 18, 2007, it
seems there are "historical" compatibility issues about wpa_supplicant and
Network Manager, mostly of them unsolved since much older versions of Fedora.

Any help or idea, please ? Correct/canonical way to go ?


Regards,
Răzvan

Comment 2 Răzvan Sandu 2007-11-02 19:39:29 UTC
The missing file's name cannot be read at boot.

wpa_supplicant *is* started at boot, in ntsysv, but it reports FAILED.

However, here's what wlassistant says in background, when launched manually:


WPA client started. Waiting for status...
==>stderr: Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or
directory
CONNECTION FAILED.

Regards,
Răzvan

Comment 3 Mike Cohler 2007-11-11 19:45:45 UTC
See my report at https://bugzilla.redhat.com/show_bug.cgi?id=375721

I have a screen image for f8 showing that the reason possibly for a missing file
may be that there is a space missing in the sequence -Dwextdbus... is it
possible that in a config file (but where?) it should instead be -Dwext dbus.... ?

Comment 4 Răzvan Sandu 2007-11-15 06:39:08 UTC

*** This bug has been marked as a duplicate of 375721 ***

Comment 5 Răzvan Sandu 2007-11-15 19:40:51 UTC

*** This bug has been marked as a duplicate of 244029 ***


Note You need to log in before you can comment on or make changes to this bug.