Bug 38464

Summary: Emacs's mh-e package doesn't work
Product: [Retired] Red Hat Linux Reporter: nessus
Component: emacsAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED WORKSFORME QA Contact: Aaron Brown <abrown>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-04-30 21:37:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description nessus 2001-04-30 21:26:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

If I try to use mh-e, it complains that it can't find 'inc' or

Reproducible: Always
Steps to Reproduce:
1. Run emacs.
2. Type "M-X mh-rmail".


Actual Results:  "Can't find 'inc' or 'mhl'."

Expected Results:  Should start up mh-e.

I tried to get the latest version of mh-e from SourceForge, but the version
I got from there had the same problem that exists in the Red Hat release. 
Eventually I found version 5.0.2 of mh-e as a tarball at


and this version works fine.

Comment 1 Trond Eivind Glomsrxd 2001-04-30 21:37:27 UTC
Works here.

Do you have nmh installed?

Comment 2 Trond Eivind Glomsrxd 2001-05-14 14:43:27 UTC
Closed - lack of feedback, and it works here.

Comment 3 nessus 2001-12-14 00:35:39 UTC
Well, yes, I have (and had) nmh installed.  If I didn't, version 5.0.2 of mh-e
wouldn't have worked for me.  The problem was that for various important reasons
that I won't go into, I have nmh installed in a non-standard place.  Earlier
versions of mh-e were quite able to cope with this.  They'd find "inc" in the
PATH environment variable and figure out the rest.  The latest version of mh-e
on SourceForge (version 5.0.92) is also able to cope with non-standard nmh
placement without problem.  For reasons unknown to me, however, there are some
versions of mh-e inbetween versions 5.0.2 and 5.0.92 (including the version that
comes with Red Hat 7.1 and 7.2) that can't cope easily with nmh being installed
in a non-standard place.