Bug 38464 - Emacs's mh-e package doesn't work
Emacs's mh-e package doesn't work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-30 17:26 EDT by nessus
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 17:37:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nessus 2001-04-30 17:26:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)


If I try to use mh-e, it complains that it can't find 'inc' or
'mhl'.

Reproducible: Always
Steps to Reproduce:
1. Run emacs.
2. Type "M-X mh-rmail".

	

Actual Results:  "Can't find 'inc' or 'mhl'."

Expected Results:  Should start up mh-e.

I tried to get the latest version of mh-e from SourceForge, but the version
I got from there had the same problem that exists in the Red Hat release. 
Eventually I found version 5.0.2 of mh-e as a tarball at

	http://www.ics.uci.edu/pub/mh/mh-e/

and this version works fine.
Comment 1 Trond Eivind Glomsrxd 2001-04-30 17:37:27 EDT
Works here.

Do you have nmh installed?
Comment 2 Trond Eivind Glomsrxd 2001-05-14 10:43:27 EDT
Closed - lack of feedback, and it works here.
Comment 3 nessus 2001-12-13 19:35:39 EST
Well, yes, I have (and had) nmh installed.  If I didn't, version 5.0.2 of mh-e
wouldn't have worked for me.  The problem was that for various important reasons
that I won't go into, I have nmh installed in a non-standard place.  Earlier
versions of mh-e were quite able to cope with this.  They'd find "inc" in the
PATH environment variable and figure out the rest.  The latest version of mh-e
on SourceForge (version 5.0.92) is also able to cope with non-standard nmh
placement without problem.  For reasons unknown to me, however, there are some
versions of mh-e inbetween versions 5.0.2 and 5.0.92 (including the version that
comes with Red Hat 7.1 and 7.2) that can't cope easily with nmh being installed
in a non-standard place.

Note You need to log in before you can comment on or make changes to this bug.