Bug 38789

Summary: qt1x demands libstdc++-libc6.1-1.so.2
Product: [Retired] Red Hat Linux Reporter: mike
Component: qt1xAssignee: Ngo Than <than>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-05-02 12:32:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description mike 2001-05-02 12:32:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2smp i686; en-US; 0.8.1)

I'm recompiling some of my software under RH7.1 (mostly), one module of
which needs qt1x, which I have installed (qt1x-1.45-12).  Unfortunately,
this version of qt1x seems to require an older (libstdc++-libc6.1-1)
version of libstdc++ than I have (libstdc++-libc6.2.2.so.3).  This is also
a problem because the older libstdc++ causes a bad problem with exception
handling anytime it's linked in.

The message I get from g++ is:
/usr/bin/ld: warning: libstdc++-libc6.1-1.so.2, needed by
/usr/lib/qt-1.45/lib/libqt.so, not found (try using --rpath)

Reproducible: Always
Steps to Reproduce:
1. link c++ program with -lqt
Comment 1 Ngo Than 2001-05-02 14:26:05 EDT
the only reason why qt1x requires libstdc++-libc6.1-1.so.2, is backward
compatibility with the old programs in RHL 6.x and 7.0.

If you want to use the new libstdc++, please uses qt-2.3.0.