This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 397601

Summary: Audio does not function on waking up from hibernate
Product: [Fedora] Fedora Reporter: Sankarshan Mukhopadhyay <sankarshan.mukhopadhyay>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: aquarichy, lkundrak, makoto, oliva, pierre-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-29 04:35:45 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 314411, 384271    
Bug Blocks:    
Attachments:
Description Flags
pulseaudio -vv output none

Description Sankarshan Mukhopadhyay 2007-11-23 23:25:57 EST
Description of problem:

Resuming from Hibernate, the audio does not function. Does work well on hard
reboot of box.

Version-Release number of selected component (if applicable):

pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8


How reproducible:

Steps to Reproduce:
1. Have audio player on, select some audio, pause
2. Hibernate machine
3. Resume from hibernate
  
Actual results:

Audio does not play

Expected results:

Audio should be able to function normally

Additional info:
Comment 1 Sankarshan Mukhopadhyay 2007-11-23 23:32:38 EST
http://smolt.fedoraproject.org/show?UUID=38ad3dc5-4242-41fe-8cb1-7b7d735f4a0d is
the smoltProfile for this box
Comment 2 Lennart Poettering 2007-11-29 20:36:12 EST
Please run pulseaudio in a terminal.

pulseaudio -k
pulseaudio -vv

Then, hibernate and resume again. And dump the output of Pulseaudio here.

Comment 3 Lennart Poettering 2007-11-29 20:36:23 EST
*** Bug 398961 has been marked as a duplicate of this bug. ***
Comment 4 Alexandre Oliva 2007-12-01 00:42:34 EST
Created attachment 274631 [details]
pulseaudio -vv output

This is what I got.  Sorry about all the noise regarding an external USB disk I
had plugged in.

Restarting pulseaudio doesn't fix it.  Somehow logging out and back in does.

Any ideas?
Comment 5 Alexandre Oliva 2007-12-01 01:02:57 EST
It seems to be a deeper problem than just audio.  The external USB disk wasn't
re-mounted after wake up, and even unplugging it and plugging it back in
produced no actions.  Shall we blame it on hal, dbus, or what?
Comment 6 Richard Schwarting 2007-12-01 12:29:43 EST
Blame Hal, I think.

I have this problem when waking up from resume.  My solution is 

pulseaudio --kill
sudo /etc/init.d/haldaemon restart
pulseaudio --log-target=syslog

And voila, 90% of the time, my problem is fixed.  This is not an idea situation,
though! I miss having audio that worked :'(
Comment 7 Lubomir Kundrak 2008-01-25 06:27:10 EST
I'd also bet on hal.
You can be sure by looking at output of following:

$ getfacl /dev/snd/pcmC0D0c

If you don't see yourself there, please close this as duplicate of bug #384271
Also, try switching virtual consoles and look if it made hal change the ACLs
Comment 8 Richard Schwarting 2008-01-25 13:13:04 EST
After hibernating once and coming back, my sound was gone, and I also didn't
appear in the in the results of getfacl /dev/snd/pcmC0D0c anymore.  Following
bug #314411, which asks the following questions, I have the following answers:

 1. Is hald running upon resume? (lshal will tell you)
Yes.

 2. Do you get the permissions back when switching to VT1 and then back? (e.g.
getfacl /dev/snd/pcmC0D0p)
Yes.

 3. Does manually fixing up the ACL's make sound work? Just wondering if it's a
low-level driver problem.
Don't know how :)

 4. What ALSA driver are you using?
I'm not sure how to find this out.  system-config-soundcard reports the
following information, though:
Model: SB450 HDA Audio, module: snd-hda-intel
I don't think that's what you want, though :)

So, I think it's the same issues as in bug #384271, because I disappear from the
ACLs after hibernating/suspend, and that is restored when switching VTs. 

Thanks for peeking in on this :D
Comment 9 Lubomir Kundrak 2008-02-29 04:35:45 EST

*** This bug has been marked as a duplicate of 384271 ***