Bug 428252

Summary: Problem with update/remove old version
Product: [Fedora] Fedora Reporter: Zdenek Kabelac <zkabelac>
Component: setroubleshootAssignee: John Dennis <jdennis>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.0.4-3.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-28 16:43:33 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
attempts to reproduce the error none

Description Zdenek Kabelac 2008-01-10 07:22:52 EST
Description of problem:
I cannot simply remove older setouubleshot package from my rawhide.
I'd had actually 3 different package version of setroubleshot package.

#rpm -qa | grep setroubleshoot
setroubleshoot-2.0.0-3.fc9.noarch
setroubleshoot-server-2.0.1-1.fc9.noarch
setroubleshoot-1.10.7-1.fc8.noarch
setroubleshoot-plugins-2.0.0-1.fc9.noarch
setroubleshoot-2.0.1-1.fc9.noarch

And I cannot easily remove older version:
setroubleshoot-1.10.7-1.fc8.noarch

# rpm -e setroubleshoot-1.10.7-1.fc8.noarch
error: %trigger(setroubleshoot-2.0.0-3.fc9.noarch) scriptlet failed, exit status 1
error: %trigger(setroubleshoot-2.0.1-1.fc9.noarch) scriptlet failed, exit status 1

Version-Release number of selected component (if applicable):
setroubleshoot-2.0.0-3.fc9.noarch

How reproducible:
yum update on the fedora rawhide

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
hmm - just one version of this package in system ?

Additional info:
Comment 1 John Dennis 2008-01-10 09:05:14 EST
Thank you for reporting this. Could you please do this for me:

ls -lZ /var/lib/setroubleshoot/

and add the output to this bugzilla, thanks.
Comment 2 John Dennis 2008-01-10 09:13:32 EST
Also, after getting the directory contents please try to remove the old rpm's,
but add this argument --notriggerpostun that should allow the removal to work.
Did that fix the problem?
Comment 3 Zdenek Kabelac 2008-01-11 05:38:07 EST
Well - of course I've removed offending packages after I've made the bugreport
with --noscript parameter - so I cannot really show the list ls -lZ from this
time - but I've made just an update and setroubleshoot-2.0.1-1.fc9.noarch was
installed again while the setroubleshoot-2.0.0-3.fc9.noarch was left in my system.

- so the current situation on my 64bit rawhide is:

# rpm -qa | grep setroubl
227816 setroubleshoot-2.0.0-3.fc9.noarch
1655432 setroubleshoot-server-2.0.1-1.fc9.noarch
231847 setroubleshoot-2.0.1-1.fc9.noarch
2423383 setroubleshoot-plugins-2.0.0-1.fc9.noarch

------
# rpm -ql setroubleshoot-2.0.0-3.fc9.noarch
/etc/xdg/autostart/sealertauto.desktop
/usr/lib/python2.5/site-packages/setroubleshoot
/usr/lib/python2.5/site-packages/setroubleshoot/browser.py
/usr/lib/python2.5/site-packages/setroubleshoot/browser.pyc
/usr/lib/python2.5/site-packages/setroubleshoot/browser.pyo
/usr/lib/python2.5/site-packages/setroubleshoot/email_dialog.py
/usr/lib/python2.5/site-packages/setroubleshoot/email_dialog.pyc
/usr/lib/python2.5/site-packages/setroubleshoot/email_dialog.pyo
/usr/lib/python2.5/site-packages/setroubleshoot/gui_utils.py
/usr/lib/python2.5/site-packages/setroubleshoot/gui_utils.pyc
/usr/lib/python2.5/site-packages/setroubleshoot/gui_utils.pyo
/usr/share/applications/setroubleshoot.desktop
/usr/share/dbus-1/services/sealert.service
/usr/share/icons/hicolor
/usr/share/icons/hicolor/96x96
/usr/share/icons/hicolor/96x96/apps
/usr/share/icons/hicolor/96x96/apps/setroubleshoot_icon.png
/usr/share/setroubleshoot/gui
/usr/share/setroubleshoot/gui/setroubleshoot_icon.png

-------
# rpm -ql  setroubleshoot-2.0.1-1.fc9.noarch
/etc/xdg/autostart/sealertauto.desktop
/usr/lib/python2.5/site-packages/setroubleshoot
/usr/lib/python2.5/site-packages/setroubleshoot/browser.py
/usr/lib/python2.5/site-packages/setroubleshoot/browser.pyc

------
# ls -lZ /var/lib/setroubleshoot/
-rw-r--r--  root root system_u:object_r:setroubleshoot_var_lib_t:s0
email_alert_recipients

--------


Comment 4 John Dennis 2008-01-11 12:55:38 EST
Created attachment 291407 [details]
attempts to reproduce the error
Comment 5 John Dennis 2008-01-11 13:05:43 EST
I haven't been able to reproduce this, see attachment. So I'm a bit perplexed.
I'm also perplexed because as far as I can tell the command run by the trigger
should always return 0, which seems to be culprit.

However, the use of a rpm trigger was probably a bad idea in the first place,
triggers are evil. So I've updated the latest rawhide package (2.0.2-1) to:

* bulletproof the exit status of the init script

* have the run time code check the database version, instead of the rpm install

* remove the trigger.

Hopefully this will be more robust.

I know others have installed from rawhide but no one else has reported this
problem yet. I'm not sure if this is a general problem or is unique to your
system. So I'm going to leave this bugzilla open for a while so others can find
it if they see the same issue. But I think the changes listed above should
address the issue.
Comment 6 Fedora Update System 2008-01-15 17:54:53 EST
setroubleshoot-2.0.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update setroubleshoot'
Comment 7 Fedora Update System 2008-02-25 21:18:47 EST
setroubleshoot-plugins-2.0.4-3.fc8,setroubleshoot-2.0.5-2.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-28 16:42:57 EST
setroubleshoot-plugins-2.0.4-3.fc8, setroubleshoot-2.0.5-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.