Bug 433153

Summary: f9 upgrade boot loader not recognised
Product: [Fedora] Fedora Reporter: cje
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NeedsRetesting
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-08 23:02:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    

Description cje 2008-02-16 18:19:01 EST
Description of problem:
i upgraded my f8 qemu vm to f9alpha using the DVD image.  during the upgrade it
didn't recognise my (default, grub) boot loader.
i think (pretty sure) the default was not to modify the current loader.  that's
what i chose.
now it's booted into the old kernel, /lib/modules only contains a folder for the
new kernel and /boot isn't mounted.  looks like it's installed the vmlinuz etc
in /boot on the main / partition which is in a logical volume.

Version-Release number of selected component (if applicable):
fedora 9 alpha

Steps to Reproduce:
1. install f8 x86_64 on a qemu vm
2. upgrade to f9 alpha from dvd image
3. accept all defaults
  
Actual results:
can boot old kernel but no modules and no /boot.

Expected results:
not that.  ;-)
Comment 1 cje 2008-02-17 10:10:16 EST
the actual message is:

"The installer is unable to detect the boot loader currently in us on your system."

the options are "Skip boot loader updating" (default) and "Create new boot
loader configuration".

last time i accepted the default.  now i'm trying again with the "Create new...".
Comment 2 cje 2008-02-17 11:29:50 EST
using the "Create new boot loader configuration" python crashes at the end of
the installation during "Installing boot loader".  i couldn't save the debug
output but the first line is:

/usr/lib/booty/bootloaderInfo.py, line 759, in writeGrub.
Comment 3 Jesse Keating 2008-04-01 17:30:38 EDT
I do believe we fixed these issues.  We'll need a retest done.
Comment 4 cje 2008-04-04 08:40:41 EDT
okay, well it did correctly detect the current setup and attempted to update it.
 But that caused another crash during "Installing boot loader".  this one has
the following in the details:

posixpath.py line 171, in exists
  st = os.stat(path)
isys.py line 765, in readFSType
bootloaderInfo.py line 65, in syncDataToDisk
bootloaderInfo.py line 637, in runGrubInstall
bootloaderInfo.py line 1077, in upgradeGrub
bootloaderInfo.py line 1099, in write
bootloaderInfo.py line 1215, in write
bootloader.py line 229, in writeBootloader

...

TypeError: coercing to Unicode: need string or buffer, instance found

Local variables in innermost frame:
path: fsentry -- device: sda1  mountpoint: /boot
  fsystem: ext3 format: 0
  ismounted: 1 options: 'defaults'
  label: /boot fsprofile: None
Comment 5 Jeremy Katz 2008-04-04 09:32:09 EDT
That's bug 438830, which was fixed for last week's snapshot
Comment 6 Jesse Keating 2008-04-08 23:02:18 EDT
I've done a bunch of upgrades lately, all worked with bootloader.  Closing this.