Bug 438830 - Anaconda exception upgrading to F9 beta
Anaconda exception upgrading to F9 beta
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 439737 440148 442593 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-25 10:38 EDT by Mat Booth
Modified: 2008-04-15 17:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 14:42:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda stack trace and log files (567.39 KB, text/plain)
2008-03-25 10:38 EDT, Mat Booth
no flags Details
anacdump.txt from f8 upgrade to f9 on thinkpad x61 (552.82 KB, text/plain)
2008-03-26 18:14 EDT, Janina Sajka
no flags Details

  None (edit)
Description Mat Booth 2008-03-25 10:38:17 EDT
Description of problem:

Anaconda 11.4.0.55 threw when trying to upgrade the boot loader in an upgrade
from F8 to F9 Beta. See attached stack trace and log files.

I downloaded the boot image for the x86_64 F9 Beta that was released today,
booted from it and chose to upgrade my existing x86_64 F8 installation using an
URL install from the site I downloaded the boot image from. I also chose to
update the boot loader during the install process (the recommended option).


Additional info:

This was on my ASUS F3SR notebook, dual core, 64bit, ATI HD2400.
Comment 1 Mat Booth 2008-03-25 10:38:17 EDT
Created attachment 299033 [details]
anaconda stack trace and log files
Comment 2 Chris Wright 2008-03-25 20:42:10 EDT
I'm seeing same backtrace (on both x86_64 and i386, and from a variety of
starting points for upgrade, F8, F9-alpha, random rawhide snapshot).
Comment 3 Janina Sajka 2008-03-26 18:14:04 EDT
Created attachment 299243 [details]
anacdump.txt from f8 upgrade to f9 on thinkpad x61

anacdump.txt from upgrade on Thinkpad X61 from F8 to F9. The new 2.6.25 kernel
from F9 was successfully
added to my grub.conf and all old F8 kernels removed, EXCEPT for the install
boot kernel
reference I created by hand. It's my way of starting the install--to copy from
the isolinux dir on
the install media and then creating a stanza referencing /boot/vmlinuz-install
and /boot/initrd-install.img
in my grub.conf. hth
Comment 4 Matěj Cepl 2008-03-27 07:10:04 EDT
If you want somebody from engineering who is able to reproduce this, let me know.
Comment 5 Jeremy Katz 2008-03-27 15:53:17 EDT
Fixed in git
Comment 6 Jeremy Katz 2008-03-31 10:52:41 EDT
*** Bug 439737 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2008-04-01 18:39:02 EDT
*** Bug 440148 has been marked as a duplicate of this bug. ***
Comment 8 Jesse Keating 2008-04-03 14:42:27 EDT
Upgrades now work, closing this.
Comment 9 Jeremy Katz 2008-04-15 17:10:48 EDT
*** Bug 442593 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.