Bug 434131

Summary: rudeconfig failed massrebuild attempt for GCC 4.3
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: rudeconfigAssignee: Matt Flood <matt>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: dcantrell, ftbfs, matt_domsch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-16 13:26:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 433629    

Description Jesse Keating 2008-02-22 13:08:38 UTC
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=439579
Exit code was 1, check the build.log for the failed buildArch task.

Comment 1 Tyler Owen 2008-02-26 12:01:02 UTC
Error in i386 build.log:

src/ConfigImpl.cpp: In static member function 'static char*
rude::config::ConfigImpl::stringToBinary(const char*, int&)':
src/ConfigImpl.cpp:248: error: 'strlen' was not declared in this scope


Comment 2 Bug Zapper 2008-05-14 05:27:09 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Matt Domsch 2008-07-03 17:36:30 UTC
*** Bug 440848 has been marked as a duplicate of this bug. ***

Comment 4 FTBFS 2008-09-05 16:26:41 UTC
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.

Comment 5 Matt Domsch 2008-09-16 13:26:03 UTC
rudeconfig-5.0.5-4.fc10.src.rpm builds now, thanks.