Bug 434312

Summary: qps failed massrebuild attempt for GCC 4.3
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: qpsAssignee: Arindam Ghosh <makghosh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: dcantrell, ftbfs, jonstanley
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-08 03:37:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 433629    

Description Jesse Keating 2008-02-22 15:58:14 UTC
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=441928
Exit code was 1, check the build.log for the failed buildArch task.

Comment 1 Jon Stanley 2008-02-29 00:57:39 UTC
.obj/pstable.o: In function `Pstable::moveCol(int, int)':
/builddir/build/BUILD/qps-1.9.19b/pstable.cpp:353: undefined reference to
`Svec<Category*>::remove(int)'


Comment 2 Bug Zapper 2008-05-14 05:29:00 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Matt Domsch 2008-07-03 16:08:17 UTC
*** Bug 440904 has been marked as a duplicate of this bug. ***

Comment 4 FTBFS 2008-09-05 16:26:17 UTC
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.

Comment 5 Arindam Ghosh 2008-09-06 09:17:02 UTC
(In reply to comment #4)

Ummm...sorry for the long outage. I couldn't find enough time to look into this earlier. But now i did some koji scratch builds with the upstream release of qps that is qps-1.10.2. It worked fine. Here are the builds:

* F10: [http://koji.fedoraproject.org/koji/taskinfo?taskID=810163]
* F9: [http://koji.fedoraproject.org/koji/taskinfo?taskID=810154]
* F8: [http://koji.fedoraproject.org/koji/taskinfo?taskID=810169]

I will update the cvs tonight and then close this bug :)

Comment 6 Arindam Ghosh 2008-09-08 03:27:58 UTC
cvs build done and bodhi updates submitted
[https://admin.fedoraproject.org/updates/qps]

Current version: qps-1.10.2-1

Closing this bug...