Bug 434360

Summary: bes failed massrebuild attempt for GCC 4.3
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: besAssignee: Patrice Dumas <pertusus>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: dcantrell, ftbfs, jonstanley, matt_domsch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-16 09:24:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 433629    

Description Jesse Keating 2008-02-22 16:04:29 UTC
This is an automatically filed bug for a failed rebuild attempt for GCC 4.3.

http://fedoraproject.org/wiki/JesseKeating/gcc43MassRebuildProposal

Please verify why this build failed and fix it.
http://koji.fedoraproject.org/koji/taskinfo?taskID=443068
Exit code was 1, check the build.log for the failed buildArch task.

Comment 1 Jon Stanley 2008-03-01 00:02:15 UTC
scratch build 480476

Comment 2 Jon Stanley 2008-03-01 00:40:20 UTC
BESKeys.cc: In constructor 'BESKeys::BESKeys(const std::string&)':
BESKeys.cc:75: warning: ignoring return value of 'char* getcwd(char*, size_t)',
declared with attribute warn_unused_result
BESKeys.cc: In constructor 'BESKeys::BESKeys(const std::string&)':
BESKeys.cc:75: warning: ignoring return value of 'char* getcwd(char*, size_t)',
declared with attribute warn_unused_result
BESKeys.cc: In constructor 'BESKeys::BESKeys(const std::string&)':
BESKeys.cc:75: warning: ignoring return value of 'char* getcwd(char*, size_t)',
declared with attribute warn_unused_result
BESKeys.cc: In member function 'bool BESKeys::break_pair(const char*,
std::string&, std::string&)':
BESKeys.cc:144: error: 'strlen' was not declared in this scope


Comment 3 Bug Zapper 2008-05-14 05:30:01 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Matt Domsch 2008-07-03 16:06:40 UTC
*** Bug 440807 has been marked as a duplicate of this bug. ***

Comment 5 FTBFS 2008-09-05 16:09:57 UTC
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.

Comment 6 Matt Domsch 2008-09-16 13:16:26 UTC
bes-3.6.2-1.fc10.src.rpm builds now, thanks.