Bug 435067

Summary: QEMU driver does not support xvd* disk device names for Xenner guests
Product: [Fedora] Fedora Reporter: Daniel Berrange <berrange>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: berrange
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-04 06:11:21 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 435059    
Attachments:
Description Flags
Support xvd* disks for xenner none

Description Daniel Berrange 2008-02-26 23:23:57 EST
Description of problem:
Xen paravirt guests are typically configured with disk names matching 'xvdXXX'.
. Attempting to do this with the QEMU driver for Xenner results in a libvirt
error message

Invalid harddisk device name: xvda

This is because the QEMU driver only accepts disks named 'hdX'. 

For xenner guests it needs to be more flexible, accepting hdX, sdX, and xvdX.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2008-05-10 13:27:05 EDT
Created attachment 305037 [details]
Support xvd* disks for xenner
Comment 2 Bug Zapper 2008-05-14 01:39:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Berrange 2008-11-04 06:11:21 EST
This is fixed in 0.4.5 release