Bug 437048

Summary: [RFE]: Please let KDE users also use gnome-packagekit
Product: [Fedora] Fedora Reporter: Sebastian Vahl <fedora>
Component: gnome-packagekitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: kevin, rdieter, rhughes
Target Milestone: ---Keywords: EasyFix, Regression, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.2.3-9.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-31 21:48:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 437058    
Bug Blocks: 235706, 421891    

Description Sebastian Vahl 2008-03-11 17:22:31 EDT
Description of problem:
PackageKit/gnome-packagekit was made default for the Beta yesterday and 
pirut/pup was removed: 
https://www.redhat.com/archives/fedora-extras-commits/2008-March/msg03215.html

Also the update tool is only started from inside gnome:
/usr/share/gnome/autostart/gnome-pk-update-icon.desktop

With this setup average KDE users wouldn't be able to install/reinstall or 
update packages because gnome-packagekit's applications weren't shown in the 
menu.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.9-1.fc9.i386

How reproducible:
ever

Steps to Reproduce:
1. Login into KDE
2. try to find contents of gnome-packagekit in kde's menu
  
Actual results:
Contents of gnome-packagekit are not shown in kde's menu

Expected results:
Contents of gnome-packagekit should be shown in kde's menu

Additional info:
I'm not aware of a qt or kde frontend for packagekit. So kde users should also 
be able to use gnome-packagekit - at least - atm. Otherwise we have to stick 
to pup/pirut or switch to smart instead.

Showing pk-update-icon in KDE's systray would be broken atm because of known 
upstream bug (which I cannot find atm).
Comment 1 Jeremy Katz 2008-03-11 18:23:28 EDT
There is work on a qt or kde frontend (I forget which), but it may not be ready
at this point.  So we should definitely remove the OnlyShowIn's until the other
interfaces are "ready"
Comment 2 Sebastian Vahl 2008-03-11 19:09:35 EDT
The last activity on the mailing lists from the qt-frontend I know is quite 
old: http://lists.freedesktop.org/archives/packagekit/2007-October/000417.html

However, it would definitively not be ready for the beta. Some further 
testings seems to also invoke a bug which could be workarounded if the 
line "NotShowIn=KDE;XFCE;" would also be removed 
from /usr/share/gnome/autostart/gnome-pk-update-icon.desktop when it's copied 
to /etc/xdg/autostart to be started for all desktops: bug #437058
Comment 3 Matthias Clasen 2008-03-13 18:43:25 EDT
I assume this bug has been addressed by the following commit ?


* Tue Mar 11 2008 Robin Norwood <rnorwood@redhat.com> - 0.1.9-2
- Apply patch to enable gnome-packagekit in KDE


Please reopen if there is another issue. 
Comment 4 Sebastian Vahl 2008-03-18 12:56:08 EDT
Could yo please move %{_datadir}/gnome/autostart/gnome-pk-update-icon.desktop 
to /etc/xdg/autostart so that it would also be autostarted in KDE? The 
upstream bug I've mentioned which crashs plasma is closed now:
http://bugs.kde.org/show_bug.cgi?id=159167
Comment 5 Robin Norwood 2008-03-19 10:23:38 EDT
Fixed in gnome-packagekit-0.1.9-4

However, the icon doesn't "look right" when I log into KDE on my rawhide box. 
About 2/3 of it is visible, the rest is cut off.  It at least works this way,
but if there's a simple fix for this that I can get in today, let me know.
Comment 6 Rex Dieter 2008-03-19 10:37:53 EDT
Robin, don't worry about the icon, fault lies not here, but elsewhere (it's more
of a gtk2 applet vs plasma interaction)
Comment 7 Robin Norwood 2008-03-19 12:02:17 EDT
I've sent a request to the rel-eng team that 0.1.9-4 get pushed into the beta
Comment 8 Sebastian Vahl 2008-07-30 17:40:39 EDT
gpk-* applications are gone again from the KDE menu in Fedora 9:

$ grep KDE /usr/share/applications/gpk-*
/usr/share/applications/gpk-application.desktop:NotShowIn=KDE;
/usr/share/applications/gpk-prefs.desktop:NotShowIn=KDE;
/usr/share/applications/gpk-repo.desktop:NotShowIn=KDE;
/usr/share/applications/gpk-update-viewer.desktop:NotShowIn=KDE;
Comment 9 Kevin Kofler 2008-07-31 00:50:03 EDT
Indeed (regression in the 0.2.x upgrade), and this is very bad because it means 
end users will get no more upgrades, they'll probably also miss the upgrade 
which will eventually fix this. The sooner this gets fixes, the better.

Note that the /usr/share/applications entries aren't the worst, 
the /etc/xdg/autostart one is.

In Rawhide, we'll want to have KPackageKit used by default eventually, but only 
once it works! And even if it was working yet, nothing would be dragging it in 
on F9.
Comment 10 Kevin Kofler 2008-07-31 00:51:22 EDT
Setting Severity to urgent because the net effect is that users will not get 
any updates at all, ever again (because they won't get the update which fixes 
this either).
Comment 11 Kevin Kofler 2008-07-31 01:49:41 EDT
The problem is that the enable-kde patch isn't applied. It's applied in the 
Rawhide package, so I assume it does apply, thus can you please apply it to the 
F9 package and issue an update directly to stable as soon as possible?
Comment 12 Robin Norwood 2008-07-31 10:02:08 EDT
I'll get this now.
Comment 13 Fedora Update System 2008-07-31 11:09:29 EDT
gnome-packagekit-0.2.3-9.fc9 has been submitted as an update for Fedora 9
Comment 14 Robin Norwood 2008-07-31 11:11:36 EDT
If someone who uses KDE could test the above update, that would be great.
Comment 15 Kevin Kofler 2008-07-31 11:13:59 EDT
I'm on it, firing up the laptop running F9 now.
Comment 16 Kevin Kofler 2008-07-31 11:22:43 EDT
Works fine here. Can you please push this directly to stable? The faster this 
gets pushed, the shorter the breakage window and thus the fewer the users 
ending up with no more updates.
Comment 17 Fedora Update System 2008-07-31 21:48:01 EDT
gnome-packagekit-0.2.3-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Richard Hughes 2008-10-27 13:57:51 EDT
Now that kpackagekit exists in rawhide, should I remove this patch for F10?
Comment 19 Rex Dieter 2008-10-27 14:21:01 EDT
Yes please.
Comment 20 Kevin Kofler 2008-10-28 00:01:49 EDT
What about people upgrading from F9? Nothing is dragging in kpackagekit for those.