Bug 437058 - gnome-pk-update-icon.desktop sin /etc/xdg/autostart would crash plasma during login
gnome-pk-update-icon.desktop sin /etc/xdg/autostart would crash plasma during...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 437048
  Show dependency treegraph
 
Reported: 2008-03-11 19:00 EDT by Sebastian Vahl
Modified: 2008-03-13 08:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 08:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
crash of plasma right after login (2.46 KB, text/plain)
2008-03-11 19:00 EDT, Sebastian Vahl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 159167 None None None Never

  None (edit)
Description Sebastian Vahl 2008-03-11 19:00:25 EDT
Description of problem:
Due to the change of making PackageKit the default graphical package manager 
I've tried to get it also working inside KDE. To test the update applet I've 
copied /usr/share/gnome/autostart/gnome-pk-update-icon.desktop 
to /etc/xdg/autostart and logged in into a clean user account. Right after the 
login plasma is crashing (backtrace is attached in the next comment)
If I remove the line "NotShowIn=KDE;XFCE;" and re-login and/or clean up the 
user account plasma isn't crashing anymore.


Version-Release number of selected component (if applicable):
gnome-packagekit-0.1.9-1.fc9.i386
kdebase-4.0.2-2.fc9.i386
kdebase-runtime-4.0.2-3.fc9.i386
kdebase-workspace-4.0.2-5.fc9.i386
kdelibs-4.0.2-10.fc9.i386
qt4-4.3.4-5.fc9.i386

How reproducible:
ever

Steps to Reproduce:
1. copy /usr/share/gnome/autostart/gnome-pk-update-icon.desktop 
to /etc/xdg/autostart
2. Login into KDE
3.
  
Actual results:
plasma is crashing

Expected results:
plasma should not crash

Additional info:
This is mostly a tracking bug for an upstream bug. So fedora specific 
discussions could be done here.
Comment 1 Sebastian Vahl 2008-03-11 19:00:25 EDT
Created attachment 297686 [details]
crash of plasma right after login
Comment 2 Sebastian Vahl 2008-03-13 07:50:27 EDT
Upstream has closed the bug a few minutes ago with this changes:
http://websvn.kde.org/?view=rev&revision=785140
Comment 3 Kevin Kofler 2008-03-13 07:56:15 EDT
Is this fix worth backporting to our packages? I'm not sure, as the bug is only 
reproducible with the NotShowIn, but maybe other applets with a legitimate 
NotShowIn=KDE can trigger this?
Comment 4 Ngo Than 2008-03-13 08:34:01 EDT
the fix is now included in kdebase-workspace-4_0_2-7_fc9

Note You need to log in before you can comment on or make changes to this bug.