Bug 438100

Summary: clock is saved but not loaded from hardware
Product: [Fedora] Fedora Reporter: Jonathan Kamens <jik>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-29 14:25:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jonathan Kamens 2008-03-19 02:08:43 UTC
initscripts save clock to hardware upon halt but do not load it on reboot.

This is fine when UTC is true in /etc/sysconfig/clock, because then the kernel
boots with the correct time already.

This is not fine when UTC is false, since then the clock is off after reboot by
whatever your timezone offset is.

Clock needs to be adjusted by init scripts on boot.

Comment 1 Bill Nottingham 2008-03-19 03:10:43 UTC
It *should* be happening already. See /etc/udev/rules.d/88-clock.rules.

Does "echo add > /sys/class/rtc/<device>/uevent" cause the clock to be set for you?

Comment 2 Jonathan Kamens 2008-03-19 20:43:14 UTC
I don't have /sys/class/rtc.  I am using 2.6.23.1-49.fc8.  I have avoided using
the kernel Rawhide kernel for a long time because it regularly hangs on my
hardware (see ticket 283161) and because vmware server 1.0.4 wouldn't run on it
(at least not when I last tried).

I just tried to use kernel-2.6.25-0.121.rc5.git4.fc9.i686 to see if the hang
and/or vmware issue has been fixed, and it stopped in the middle of booting. 
Didn't hang, exactly, since the keyboard was still active and ctrl-alt-delete a
few times got it to reboot, but it never got to the point of running init
scripts.  Is that a known issue when upgrading from a pre-FC9 system?  Any
suggestions?


Comment 3 Bill Nottingham 2008-03-20 02:41:24 UTC
Hm, I wonder if we need to require a new enough kernel. Still, there should be
*some* rtc device event that triggers this.

Comment 4 Bug Zapper 2008-05-14 06:42:58 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Bill Nottingham 2008-05-29 14:25:51 UTC
Whoops, found the error. Setting as a duplicate of the (later) bug with a patch.

*** This bug has been marked as a duplicate of 447019 ***