Bug 438100 - clock is saved but not loaded from hardware
clock is saved but not loaded from hardware
Status: CLOSED DUPLICATE of bug 447019
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-18 22:08 EDT by Jonathan Kamens
Modified: 2014-03-16 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-29 10:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-03-18 22:08:43 EDT
initscripts save clock to hardware upon halt but do not load it on reboot.

This is fine when UTC is true in /etc/sysconfig/clock, because then the kernel
boots with the correct time already.

This is not fine when UTC is false, since then the clock is off after reboot by
whatever your timezone offset is.

Clock needs to be adjusted by init scripts on boot.
Comment 1 Bill Nottingham 2008-03-18 23:10:43 EDT
It *should* be happening already. See /etc/udev/rules.d/88-clock.rules.

Does "echo add > /sys/class/rtc/<device>/uevent" cause the clock to be set for you?
Comment 2 Jonathan Kamens 2008-03-19 16:43:14 EDT
I don't have /sys/class/rtc.  I am using  I have avoided using
the kernel Rawhide kernel for a long time because it regularly hangs on my
hardware (see ticket 283161) and because vmware server 1.0.4 wouldn't run on it
(at least not when I last tried).

I just tried to use kernel-2.6.25-0.121.rc5.git4.fc9.i686 to see if the hang
and/or vmware issue has been fixed, and it stopped in the middle of booting. 
Didn't hang, exactly, since the keyboard was still active and ctrl-alt-delete a
few times got it to reboot, but it never got to the point of running init
scripts.  Is that a known issue when upgrading from a pre-FC9 system?  Any
Comment 3 Bill Nottingham 2008-03-19 22:41:24 EDT
Hm, I wonder if we need to require a new enough kernel. Still, there should be
*some* rtc device event that triggers this.
Comment 4 Bug Zapper 2008-05-14 02:42:58 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 5 Bill Nottingham 2008-05-29 10:25:51 EDT
Whoops, found the error. Setting as a duplicate of the (later) bug with a patch.

*** This bug has been marked as a duplicate of 447019 ***

Note You need to log in before you can comment on or make changes to this bug.