Bug 442097

Summary: libxslt-1.1.23 misinterprets the fedora comps-cleanup.xsl
Product: [Fedora] Fedora Reporter: Nicolas Mailhot <nicolas.mailhot>
Component: libxsltAssignee: Daniel Veillard <veillard>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-24 19:57:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706    
Attachments:
Description Flags
the stylesheet
none
the XML none

Description Nicolas Mailhot 2008-04-11 13:56:58 EDT
Description of problem:

The xslt file packagers use every few days to cleanup and sort Fedora comps
files before committing just stopped working

http://cvs.fedoraproject.org/viewcvs/comps/comps-cleanup.xsl

It was last changed four months ago
It worked at least a few weeks ago
libxslt OTOH was updated to a new version two days ago.

Therefore it looks like this new version is broken

Version-Release number of selected component (if applicable):

libxslt-1.1.23-1.fc9.x86_64
Comment 1 Daniel Veillard 2008-04-12 11:48:44 EDT
Created attachment 302228 [details]
the stylesheet
Comment 2 Daniel Veillard 2008-04-12 11:50:07 EDT
Created attachment 302229 [details]
the XML
Comment 3 Daniel Veillard 2008-04-12 11:51:06 EDT
Please provide the data when reporting bugs. I was able to reproduce the
problem with this set.
Comment 4 Daniel Veillard 2008-04-12 11:57:13 EDT
Seems there is a key initialization problem running xsltproc -v for the
old and the new version, the old one was for example initializing 
-xsltInitCtxtKey: /comps/group evaluates to 141 nodes
and /comps/group initialization can't be found in the new version.
Seems there is a bug there, we are missing at least some key init.

Daniel
Comment 5 Nicolas Mailhot 2008-04-12 12:59:22 EDT
The data is in the same place as the stylesheet (the comps files in
http://cvs.fedoraproject.org/viewcvs/comps/ )

Previous effects of the stylesheet have been recorded in cvs,  for example
between revision 1.319 and 1.320 of
http://cvs.fedoraproject.org/viewcvs/comps/comps-f9.xml.in

(xsltproc has tended to add an annoying empty xmlns attribute to the root
element those past months, but that's probably another problem)
Comment 6 Jeremy Katz 2008-04-24 17:29:29 EDT
Should be fixed with libxslt-1.1.23-2.fc9
Comment 7 Bill Nottingham 2008-04-24 19:57:06 EDT
Tested, works now.
Comment 8 Daniel Veillard 2008-05-09 09:52:24 EDT
Real fix hit libxslt SVN head today, libxslt-1.1.24 should show up soon,

Daniel