Bug 442097 - libxslt-1.1.23 misinterprets the fedora comps-cleanup.xsl
Summary: libxslt-1.1.23 misinterprets the fedora comps-cleanup.xsl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxslt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2008-04-11 17:56 UTC by Nicolas Mailhot
Modified: 2008-05-09 13:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 23:57:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the stylesheet (7.46 KB, application/xml)
2008-04-12 15:48 UTC, Daniel Veillard
no flags Details
the XML (1.15 MB, text/xml)
2008-04-12 15:50 UTC, Daniel Veillard
no flags Details

Description Nicolas Mailhot 2008-04-11 17:56:58 UTC
Description of problem:

The xslt file packagers use every few days to cleanup and sort Fedora comps
files before committing just stopped working

http://cvs.fedoraproject.org/viewcvs/comps/comps-cleanup.xsl

It was last changed four months ago
It worked at least a few weeks ago
libxslt OTOH was updated to a new version two days ago.

Therefore it looks like this new version is broken

Version-Release number of selected component (if applicable):

libxslt-1.1.23-1.fc9.x86_64

Comment 1 Daniel Veillard 2008-04-12 15:48:44 UTC
Created attachment 302228 [details]
the stylesheet

Comment 2 Daniel Veillard 2008-04-12 15:50:07 UTC
Created attachment 302229 [details]
the XML

Comment 3 Daniel Veillard 2008-04-12 15:51:06 UTC
Please provide the data when reporting bugs. I was able to reproduce the
problem with this set.

Comment 4 Daniel Veillard 2008-04-12 15:57:13 UTC
Seems there is a key initialization problem running xsltproc -v for the
old and the new version, the old one was for example initializing 
-xsltInitCtxtKey: /comps/group evaluates to 141 nodes
and /comps/group initialization can't be found in the new version.
Seems there is a bug there, we are missing at least some key init.

Daniel

Comment 5 Nicolas Mailhot 2008-04-12 16:59:22 UTC
The data is in the same place as the stylesheet (the comps files in
http://cvs.fedoraproject.org/viewcvs/comps/ )

Previous effects of the stylesheet have been recorded in cvs,  for example
between revision 1.319 and 1.320 of
http://cvs.fedoraproject.org/viewcvs/comps/comps-f9.xml.in

(xsltproc has tended to add an annoying empty xmlns attribute to the root
element those past months, but that's probably another problem)

Comment 6 Jeremy Katz 2008-04-24 21:29:29 UTC
Should be fixed with libxslt-1.1.23-2.fc9

Comment 7 Bill Nottingham 2008-04-24 23:57:06 UTC
Tested, works now.

Comment 8 Daniel Veillard 2008-05-09 13:52:24 UTC
Real fix hit libxslt SVN head today, libxslt-1.1.24 should show up soon,

Daniel


Note You need to log in before you can comment on or make changes to this bug.