Bug 443076

Summary: xine and xine backed applications skip while playing audio.
Product: [Fedora] Fedora Reporter: Josef Bacik <jbacik>
Component: xine-libAssignee: Aurelien Bompard <gauret>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: rdieter, robatino, ville.skytta
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-23 14:10:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Josef Bacik 2008-04-18 15:09:08 UTC
Description of problem:
Playing any audio from any application backed by xine (amarok, kde, xine-ui)
results in skipping every ~5 seconds.  I tried changing to ALSA specifically for
xine, and that helped before, but now nothing I do makes it play nicely.

Version-Release number of selected component (if applicable):
xine-lib-1.1.11.1-2.fc9.x86_64
xine-lib-arts-1.1.11.1-2.fc9.x86_64
xine-lib-pulseaudio-1.1.11.1-2.fc9.x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1.Play music
2....
3.No profit
  
Actual results:
Skipping audio

Expected results:
No skipping audio

Additional info:
This happens with FLAC/ogg/whatever.  Xmms, rythmbox, stuff that don't use xine
work fine.

Comment 1 Rex Dieter 2008-04-18 15:26:27 UTC
Fwiw, I got a sample audio file from josef and couldn't reproduce (worked fine
here playing with amarok)

Comment 2 Josef Bacik 2008-05-02 19:45:32 UTC
still happening as of the update this morning.

Comment 3 Josef Bacik 2008-05-02 19:46:21 UTC
(josef@localhost)(993/pts/4)(03:47pm:05/02/08)-
(%:~)- rpm -q xine-lib-arts xine-lib xine-lib-pulseaudio
xine-lib-arts-1.1.12-2.fc9.x86_64
xine-lib-1.1.12-2.fc9.x86_64
xine-lib-pulseaudio-1.1.12-2.fc9.x86_64

Comment 4 Bug Zapper 2008-05-14 09:39:08 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Benji Philpott 2008-05-23 13:00:07 UTC
I previously had this problem using any program with the xine engine.  It
applied to both audio and video.  However, when I removed the
alsa-plugins-pulseaudio.i386 0:1.0.16-4.fc9 rpm the problem went away.

Comment 6 Josef Bacik 2008-05-23 13:31:20 UTC
tried that, still have the same problem.

Comment 7 Benji Philpott 2008-05-23 16:37:31 UTC
Actually, I still have the problem, it would appear.  Sorry for the
mis-information...

Comment 8 Andre Robatino 2008-05-27 19:58:31 UTC
Is this related to, or the same as, bug #446192?

Comment 9 Roberto Malinverni 2008-05-29 20:21:21 UTC
Just installed F9 - I can confirm the same "xine skipping" issue with audio.
MPlayer seems to work fine.

Comment 10 Josef Bacik 2008-05-30 12:31:53 UTC
with the newest kernel the problem went away for me.

Comment 11 CS Wagner 2008-06-03 12:41:22 UTC
I've begun to notice a trend...
I don't run hald by default and pulseaudio requires it to be running (though it
gives a cryptic error instead of saying "Start HalD").  When pulseaudio fails, I
get a "permission denied" error for /dev/dsp.  So, I chmod ugo+rw /dev/dsp. 
Then, I realize I need to start hald.  Then, I start pulseaudio.  Then, xine
skips every few seconds.

However, if I remember to start hald first, pulseaudio starts automatically and
I get no skipping.  The only real difference is that I didn't chmod ugo+rw
/dev/dsp.  So, is it a coincidence or is there some odd relationship between
xine and /dev/dsp?

Comment 12 Rex Dieter 2008-09-05 15:20:35 UTC
My guess is that the issues described here are more likely due to hw/audio driver bugs and/or pulseaudio-related issues.

Can everyone experiencing this provide details wrt:
1.  audio hw/driver in use
2.  using pulseaudio or not (default is yes)

Comment 13 Kyle Pablo 2008-10-14 03:40:28 UTC
I have the same problem.  When playing mp3s in amarok, sound skips but in rhythmebox sound does not skip.

Comment 14 Kyle Pablo 2008-10-14 03:52:48 UTC
Correction:  mp3s in both Amarok and Rhythmbox are skipping.  So the problem is not xine.  I just uninstalled alsa-plugins-pulseaudio and that did not seem to make a difference.


2.6.26.5-45.fc9.x86_64
amarok-1.4.10-1.fc9.x86_64
xine-lib-1.1.15-1.fc9.x86_64
xine-lib-pulseaudio-1.1.15-1.fc9.x86_64
rhythmbox-0.11.6-2.fc9.x86_64

Comment 15 Rex Dieter 2008-10-14 11:30:10 UTC
What audio hw/drivers are folks using?  (My hunch is that it is a kernel/driver issue).

Comment 16 Rex Dieter 2009-01-23 14:04:27 UTC
Ping, awaiting feedback... If I receive none within 30-days, will close this.

Comment 17 Josef Bacik 2009-01-23 14:10:26 UTC
i've not had this problem for a bit.  i'll close the bz.