Bug 443076 - xine and xine backed applications skip while playing audio.
xine and xine backed applications skip while playing audio.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 11:09 EDT by Josef Bacik
Modified: 2009-01-23 09:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 09:10:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2008-04-18 11:09:08 EDT
Description of problem:
Playing any audio from any application backed by xine (amarok, kde, xine-ui)
results in skipping every ~5 seconds.  I tried changing to ALSA specifically for
xine, and that helped before, but now nothing I do makes it play nicely.

Version-Release number of selected component (if applicable):
xine-lib-1.1.11.1-2.fc9.x86_64
xine-lib-arts-1.1.11.1-2.fc9.x86_64
xine-lib-pulseaudio-1.1.11.1-2.fc9.x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1.Play music
2....
3.No profit
  
Actual results:
Skipping audio

Expected results:
No skipping audio

Additional info:
This happens with FLAC/ogg/whatever.  Xmms, rythmbox, stuff that don't use xine
work fine.
Comment 1 Rex Dieter 2008-04-18 11:26:27 EDT
Fwiw, I got a sample audio file from josef and couldn't reproduce (worked fine
here playing with amarok)
Comment 2 Josef Bacik 2008-05-02 15:45:32 EDT
still happening as of the update this morning.
Comment 3 Josef Bacik 2008-05-02 15:46:21 EDT
(josef@localhost)(993/pts/4)(03:47pm:05/02/08)-
(%:~)- rpm -q xine-lib-arts xine-lib xine-lib-pulseaudio
xine-lib-arts-1.1.12-2.fc9.x86_64
xine-lib-1.1.12-2.fc9.x86_64
xine-lib-pulseaudio-1.1.12-2.fc9.x86_64
Comment 4 Bug Zapper 2008-05-14 05:39:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Benji Philpott 2008-05-23 09:00:07 EDT
I previously had this problem using any program with the xine engine.  It
applied to both audio and video.  However, when I removed the
alsa-plugins-pulseaudio.i386 0:1.0.16-4.fc9 rpm the problem went away.
Comment 6 Josef Bacik 2008-05-23 09:31:20 EDT
tried that, still have the same problem.
Comment 7 Benji Philpott 2008-05-23 12:37:31 EDT
Actually, I still have the problem, it would appear.  Sorry for the
mis-information...
Comment 8 Andre Robatino 2008-05-27 15:58:31 EDT
Is this related to, or the same as, bug #446192?
Comment 9 Roberto Malinverni 2008-05-29 16:21:21 EDT
Just installed F9 - I can confirm the same "xine skipping" issue with audio.
MPlayer seems to work fine.
Comment 10 Josef Bacik 2008-05-30 08:31:53 EDT
with the newest kernel the problem went away for me.
Comment 11 CS Wagner 2008-06-03 08:41:22 EDT
I've begun to notice a trend...
I don't run hald by default and pulseaudio requires it to be running (though it
gives a cryptic error instead of saying "Start HalD").  When pulseaudio fails, I
get a "permission denied" error for /dev/dsp.  So, I chmod ugo+rw /dev/dsp. 
Then, I realize I need to start hald.  Then, I start pulseaudio.  Then, xine
skips every few seconds.

However, if I remember to start hald first, pulseaudio starts automatically and
I get no skipping.  The only real difference is that I didn't chmod ugo+rw
/dev/dsp.  So, is it a coincidence or is there some odd relationship between
xine and /dev/dsp?
Comment 12 Rex Dieter 2008-09-05 11:20:35 EDT
My guess is that the issues described here are more likely due to hw/audio driver bugs and/or pulseaudio-related issues.

Can everyone experiencing this provide details wrt:
1.  audio hw/driver in use
2.  using pulseaudio or not (default is yes)
Comment 13 Kyle Pablo 2008-10-13 23:40:28 EDT
I have the same problem.  When playing mp3s in amarok, sound skips but in rhythmebox sound does not skip.
Comment 14 Kyle Pablo 2008-10-13 23:52:48 EDT
Correction:  mp3s in both Amarok and Rhythmbox are skipping.  So the problem is not xine.  I just uninstalled alsa-plugins-pulseaudio and that did not seem to make a difference.


2.6.26.5-45.fc9.x86_64
amarok-1.4.10-1.fc9.x86_64
xine-lib-1.1.15-1.fc9.x86_64
xine-lib-pulseaudio-1.1.15-1.fc9.x86_64
rhythmbox-0.11.6-2.fc9.x86_64
Comment 15 Rex Dieter 2008-10-14 07:30:10 EDT
What audio hw/drivers are folks using?  (My hunch is that it is a kernel/driver issue).
Comment 16 Rex Dieter 2009-01-23 09:04:27 EST
Ping, awaiting feedback... If I receive none within 30-days, will close this.
Comment 17 Josef Bacik 2009-01-23 09:10:26 EST
i've not had this problem for a bit.  i'll close the bz.

Note You need to log in before you can comment on or make changes to this bug.