Bug 444730

Summary: kdm crashes after upgrade to F-9 due to missing theme
Product: [Fedora] Fedora Reporter: Dean Mander <knolderpoor>
Component: kdebase-workspaceAssignee: Rex Dieter <rdieter>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: fedora, kevin, ltinkl, rdieter, than
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-10 08:09:51 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    

Description Dean Mander 2008-04-30 07:23:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008042509 Fedora/3.0-0.55.beta5.fc9 Firefox/3.0b5

Description of problem:
error when kdm starts after upgrade to F-9 preview:

"Cannot parse theme file /usr/share/apps/kdm/themes/FedoraInfinity"
then it exits and I'm dropped to VT1.

After setting an existing theme in /etc/kde/kdm/kdmrc, the problem is gone.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.0.3-18.fc9.x86_64 (kdm)

How reproducible:
Always


Steps to Reproduce:
1. upgrade from F-8 (kde 3.5 with Fedora Infinity Theme)
2. to F-9 preview
3. with DISPLAYMANAGER="KDE" in /etc/sysconfig/desktop



Actual Results:


Expected Results:
I would expect, if the theme disappears during upgrade, that it is automatically replaced by a/the new one.

Secondly, KDM should use "no" or the "default" team rather than stopping and halting X.

When switching to GDM, there is a similar error warning on the missing theme, but gdm keeps on running with the "default" theme.



Additional info:
Comment 1 Rex Dieter 2008-04-30 07:27:57 EDT
Old themes simply aren't compatible.  The new default theme is FedoraWaves.

> Secondly, KDM should use "no" or the "default" team rather than stopping and
halting X.

I agree, please report that upstream to bugs.kde.org.
Comment 2 Dean Mander 2008-05-01 04:49:33 EDT
> Old themes simply aren't compatible.  The new default theme is FedoraWaves.
If so, why isn't the incompatible theme changed during my offline upgrade?
Without, it just breaks the system.

I mean, that kind of stuff is exactly the excuse why Fedora promotes offline
rather than live upgrades, so the installer can notify and fix stuff that breaks
because of the upgrade.
Comment 3 Dean Mander 2008-05-01 05:09:51 EDT
> I agree, please report that upstream to bugs.kde.org.
for the second problem: http://bugs.kde.org/show_bug.cgi?id=161480
Comment 4 Rex Dieter 2008-05-01 07:27:35 EDT
Reopening.

Early on in the dev-cycle, I hit that "can't open Theme" error, but it at least
didn't crash X.  I'll try to confirm that.
Comment 5 Rex Dieter 2008-05-01 07:29:52 EDT
Ick, ok, confirmed, will continue to track upstream.
Comment 6 Rex Dieter 2008-05-01 07:32:10 EDT
ok, sorry for the bz spam, reopening, I've got some possible ideas here, mostly
involving %post hacks to check for valid/existing themes.
Comment 7 Kevin Kofler 2008-05-01 07:37:44 EDT
Something like "If Theme in 
{Bluecurve,FedoraDNA,FedoraFlyingHigh,FedoraInfinity} change Theme to 
FedoraWaves" should work.
Comment 8 Kevin Kofler 2008-05-01 07:41:17 EDT
In sed, that would be:
sed -i -e 's!^Theme=/usr/share/apps/kdm/themes/(Bluecurve|FedoraDNA|
FedoraFlyingHigh|
FedoraInfinity)$!Theme=/usr/share/kde4/apps/kdm/themes/FedoraWaves!g' /etc/kde/kdm/kdmrc
or a catch-all to replace all KDM 3 themes:
sed -i -e 's!^Theme=/usr/share/apps/kdm/themes/.*$!Theme=/usr/share/kde4/apps/kdm/themes/FedoraWaves!g' /etc/kde/kdm/kdmrc
(please test before committing ;-) ).
Comment 9 Rex Dieter 2008-05-01 10:02:19 EDT
A version of hack from comment #8 is going in kde-settings-4.0-22
Comment 10 Rex Dieter 2008-05-01 10:17:41 EDT
fixed build available, please test:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47798
Comment 11 Dean Mander 2008-05-01 16:20:22 EDT
Tested but failed.

The %{_kde4_datadir} variable in the specfile must be incorrect,
because it replaces

/usr/share/apps/kdm/themes/FedoraInfinity
with
/usr/share/apps/kdm/themes/FedoraWaves

while the actual theme is located in:
/usr/share/kde4/apps/kdm/themes/FedoraWaves

Comment 12 Rex Dieter 2008-05-01 16:35:51 EDT
Hmm... it worked here.  I'll have to retest and doublecheck.
Comment 13 Kevin Kofler 2008-05-01 16:43:11 EDT
You used %{_kde4_datadir}/apps instead of %{_kde4_appsdir} (which 
is %{_kde4_datadir}/kde4/apps).
Comment 14 Kevin Kofler 2008-05-01 17:04:00 EDT
Should be fixed in kde-settings-4.0-22.fc9.1:
http://koji.fedoraproject.org/koji/buildinfo?buildID=47829
Comment 15 Dean Mander 2008-05-01 18:27:30 EDT
Confirmed. This fixes the problem.
Great work!