Bug 445517

Summary: Anaconda crashed during selecting packages (installation mode)
Product: [Fedora] Fedora Localization Reporter: Arkady L. Shane <atigro>
Component: Russian [ru]Assignee: Andrew Martynov <andrewm>
Status: CLOSED NEXTRELEASE QA Contact: Yulia <ypoyarko>
Severity: urgent Docs Contact:
Priority: low    
Version: unspecifiedCC: dimitris, r.landmann, stickster, thesource, trans-ru, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-08 14:20:10 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Updated translation for f9-branch
none
Anaconda update disk to fix installation in Russian none

Description Arkady L. Shane 2008-05-07 07:44:08 EDT
Description of problem:
This does not present in english, but it present for russian language.

Version-Release number of selected component (if applicable):
I tested it on 9-Preview and last rawhide snapshot (build via pungi)

How reproducible:
Always

Steps to Reproduce:
1. Select russian language, russian keyboard.
2. Press "Next" until selection of repositories.
3. Click on "Customize now" (Настроить сейчас) radio button at the bottom of
screen, press "Next"
4. Click on any checkbox (for example click on KDE)
  
Actual results:
Anaconda crashed

Additional info:
I can't attach trace as anaconda does not suggest to save it on disk, and i
don't know how to save it.
Comment 1 Jeremy Katz 2008-05-07 09:30:02 EDT
This is a translation bug -- the plural of "%d of %d optional package selected"
is missing the format strings to be replaced
Comment 2 Dimitris Glezos 2008-05-07 10:02:37 EDT
Assigning bug to Andrew, the maintainer for Russian
(http://fedoraproject.org/wiki/AndrewMartynov).
Comment 3 Andrew Martynov 2008-05-07 10:31:43 EDT
f9-branch in anaconda tree already contains translation made by Yulia Poyarkova:

#: ../iw/GroupSelector.py:482
#, python-format
msgid "%d of %d optional package selected"
msgid_plural "%d of %d optional packages selected"
msgstr[0] "Выбран %d дополнительный пакет из %d"
msgstr[1] "Выбрано %d дополнительных пакетов из %d"
msgstr[2] "Дополнительных пакетов нет"

Unfortunally I`m not able to run anaconda with updated .po files now and check
if bug is solved.
Comment 4 Arkady L. Shane 2008-05-07 15:47:49 EDT
Line msgstr[2] "Дополнительных пакетов нет" won't compile with msgfmt as it
should contain %d %d.
Comment 5 Andrew Martynov 2008-05-08 03:16:45 EDT
Created attachment 304839 [details]
Updated translation for f9-branch
Comment 6 Andrew Martynov 2008-05-08 03:20:31 EDT
You are right. I retranslated this phases set and uploaded new .po file into
anaconda master branch.

Currently I`m not able to update f9-branch directly via
https://translate.fedoraproject.org/submit/module/anaconda. So I attached file
here. 
Comment 7 Arkady L. Shane 2008-05-08 11:23:59 EDT
This problem is still present in released today Fedora 9!!!!!!!!!!! 
Comment 8 Bill Nottingham 2008-05-08 11:38:49 EDT
Well, yes. The issue wasn't discovered in time, and the fix wasn't provided in
time to be integrated, 
Comment 9 Paul W. Frields 2008-05-08 11:48:55 EDT
Bill -- can we provide detailed instructions on how people can download and
prepare an Anaconda update for their systems to fix this problem?
Comment 10 Dimitris Glezos 2008-05-08 11:59:36 EDT
(In reply to comment #6)
> Currently I`m not able to update f9-branch directly via
> https://translate.fedoraproject.org/submit/module/anaconda.

f9-branch added to Transifex:

https://translate.fedoraproject.org/submit/module/anaconda?branch=f9-branch
Comment 11 Bill Nottingham 2008-05-08 12:03:25 EDT
To work around this issue, the user has two choices:

1) Install in a different language, and switch the system language/locale to
Russian after installing.
2) Create an updates image with the fixed ru.po file and use it as described in
http://fedoraproject.org/wiki/Anaconda/Updates
Comment 12 Arkady L. Shane 2008-05-08 12:12:16 EDT
There are five days till release, is it really not possible to respin?
Comment 13 Chris Lumens 2008-05-08 12:21:52 EDT
No, respinning means testing an entirely new set of media and syncing it all to
the mirrors.  That stuff takes time, which is why we have to stop fixing bugs
and building new packages several days before the actual release date.
Comment 14 Andrew Martynov 2008-05-08 12:53:55 EDT
Ok, I will prepare anaconda update image to test installation of released ISO 
with new .po file and will post report here. 
Comment 15 Dimitris Glezos 2008-05-08 13:16:55 EDT
A couple of things we could do is to mention in the release notes the presence
of this bug and it's workaround (install in English, switch later).

Also, we could have a re-spin created (either through Fedora, a Fedora
contributor, or Fedora Unity) and promptly mention it in Russian websites, and
even on the Russian translation of fedoraproject.org.
Comment 16 Jeroen van Meeuwen 2008-05-08 15:03:48 EDT
For anyone to be able to re-spin anything, an update to anaconda should hit the
repositories. I've stressed this before on the mailing list for anaconda
development[1], as well as in private email to some of the people involved, but
it has come to a sudden halt because (or so I understand) 'developing anaconda
is time-consuming enough as it is, and also maintaining (old versions of)
anaconda would only make it worse'.

Again though this is a perfect example of why this should change.

Now, because anaconda does _not_ get updates pushed to the appropriate Fedora
repositories, and Unity does back-port fixes for their Re-Spins[2], the fix for
this will hit http://www.kanarip.com/anaconda/f9 as soon as Unity starts
creating a Re-Spin for Fedora 9 or possibly sooner, and it'll remain there for
the duration of Fedora 9's lifecycle, available to everyone doing Re-Spins. A
little how-to on including these repositories can be found on my blog[3].

[1] https://www.redhat.com/archives/anaconda-devel-list/2008-January/msg00089.html

[2] http://git.kanarip.com/?p=anaconda (lacking commit access to upstream
repository, I'm sorry)

[3] http://blogs.fedoraunity.org/kanarip/2008/02/03/updates-to-anaconda
Comment 17 Andrew Martynov 2008-05-11 08:54:23 EDT
Created attachment 305063 [details]
Anaconda update disk to fix installation in Russian

I spent more than 5 hours to find correct solution. Anacoda code have too much
bindings to /usr/share/locale directory and where no simple way to update .mo
file (both for gui and tui modes).

After all my attempts I decided to directly block translation of some strings
in Python code. 

During investigation I found that anaconda did not install in TEXT mode also
due to unicode translation. I will post bugreport later.
Comment 18 Andrew Martynov 2008-05-11 13:59:31 EDT
Simple instructions for Russian speaking users is published at
http://fedoraproject.org/wiki/ru_RU/Releases/9/InstallationFailed

I`m planning to update Release Notes translation and include short 
description of workaround.
Comment 19 Jeremy Katz 2008-05-15 18:00:26 EDT
*** Bug 446601 has been marked as a duplicate of this bug. ***
Comment 20 Piotr Drąg 2008-11-08 14:20:10 EST
Fixed for master and F10, as msgid_plural is gone from PO files.