Bug 448138

Summary: Yum is not cleaning its cache properly
Product: Red Hat Enterprise Linux 5 Reporter: Patrice Guay <froggy>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: low    
Version: 5.2   
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-23 14:33:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Example repository configuration file none

Description Patrice Guay 2008-05-23 14:15:25 EDT
Description of problem:
Yum "clean" option is not working correctly if a repository is configured in
/etc/yum.repos.d/

Version-Release number of selected component (if applicable):
yum-3.2.8-9.el5_2.1

How reproducible:
100%

Steps to Reproduce:
1. Create a yum repository configuration file in /etc/yum.repos.d
2. yum clean all
3. Error: Repository <repo> is listed more than once in the configuration
  
Actual results:
The yum cache is not cleared

Expected results:
The yum cache should be cleared

Additional info:
Comment 1 Patrice Guay 2008-05-23 14:15:25 EDT
Created attachment 306531 [details]
Example repository configuration file
Comment 2 James Antill 2008-05-23 14:33:25 EDT

*** This bug has been marked as a duplicate of 448012 ***