This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 456034

Summary: gnome-disk-utility - GNOME Disk Utility
Product: [Fedora] Fedora Reporter: David Zeuthen <davidz>
Component: Package ReviewAssignee: Matthias Clasen <mclasen>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: fedora-package-review, mclasen, notting
Target Milestone: ---Flags: mclasen: fedora‑review+
kevin: fedora‑cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-24 00:23:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Comment 1 David Zeuthen 2008-07-20 22:14:56 EDT
See also bug 456032 and bug 456033.
Comment 2 David Zeuthen 2008-07-20 22:20:21 EDT
How to try this out

 - Build and install DeviceKit packages (bug 456032)
 - Build and install DeviceKit-disks packages (bug 456033)
 - Build and install gnome-disk-utility packages (this bug)

Either reboot or run /sbin/start_udev - this is needed because some new udev
rules are installed. Now you can run "palimpsest" (it's also available as
Applications -> System Tools -> Palimpsest Disk Utility).
Comment 3 Matthias Clasen 2008-07-21 00:25:09 EDT
Misses PolicyKit-gnome-devel BR
Comment 4 Matthias Clasen 2008-07-21 00:28:22 EDT
and libsexy-devel
Comment 5 Matthias Clasen 2008-07-21 00:36:07 EDT
and intltool
Comment 6 Matthias Clasen 2008-07-21 11:26:20 EDT
rpmlint says:

[mclasen@golem ~]$ rpmlint gnome-disk-utility-*
gnome-disk-utility.i386: W: no-documentation
gnome-disk-utility-libs.i386: E: zero-length
/usr/share/doc/gnome-disk-utility-0.1/HACKING
gnome-disk-utility-ui-devel.i386: W: no-documentation
gnome-disk-utility-ui-libs.i386: W: no-documentation
gnome-disk-utility-ui-libs.i386: E: postun-without-ldconfig
/usr/lib/libgdu-gtk.so.0.0.0
gnome-disk-utility-ui-libs.i386: E: non-empty-%postun /sbin/ldconfig
6 packages and 0 specfiles checked; 3 errors, 3 warnings.

the no-docs can be ignored, the errors should be fixed.
Comment 7 Matthias Clasen 2008-07-21 11:49:32 EDT
package name: ok
spec file name: ok
packaging guidelines: 
  - source tag should be fixed up according to 
    https://fedoraproject.org/wiki/Packaging/SourceURL
  - the description should be more than a repetition of the summary. 
    Ideally 1-2 complete sentences.
license: ok
license field: ok
license file: ok
spec language: ok
spec legibility: ok
upstream sources: ok, but see above for the source tag
buildable: ok
ExcludeArch: n/a
BuildRequires: missing PolicyKit-gnome-devel, libsexy-devel, intltool
locale handling:
  - you should use find-lang --with-gnome %{name}, then it also picks
    up the translated docs and adds proper %locale tags for them
ldconfig: ok
relocatable: n/a
directory ownership: 
  - /usr/share/omf/palimpsest/ needs to be owned. See above for how to
    fix that with find-lang
  - /usr/include/gnome-disk-utility/ must be owned 
duplicate files: ok
permissions: 
  libs and ui-libs are missing a %defattr
%clean: ok
macro use: consistent
content: permissible
large docs: n/a
%doc content: ok
headers: ok
static libs: n/a
pc files: ok
shared libs: ok
devel deps: ok
libtool archives: ok
gui apps: ok
directory ownership: ok
%install: ok
utf8 filenames: ok




Comment 8 David Zeuthen 2008-07-21 13:43:11 EDT
(In reply to comment #6)
> [mclasen@golem ~]$ rpmlint gnome-disk-utility-*
> gnome-disk-utility.i386: W: no-documentation
> gnome-disk-utility-libs.i386: E: zero-length
> /usr/share/doc/gnome-disk-utility-0.1/HACKING

Fine. It's now one byte. Stupid tools.

> gnome-disk-utility-ui-devel.i386: W: no-documentation
> gnome-disk-utility-ui-libs.i386: W: no-documentation
> gnome-disk-utility-ui-libs.i386: E: postun-without-ldconfig
> /usr/lib/libgdu-gtk.so.0.0.0
> gnome-disk-utility-ui-libs.i386: E: non-empty-%postun /sbin/ldconfig

Excuse me? There's already 

 %post ui-libs -p /sbin/ldconfig
 %postun ui-libs -p /sbin/ldconfig

> 6 packages and 0 specfiles checked; 3 errors, 3 warnings.
>
> the no-docs can be ignored, the errors should be fixed.

(In reply to comment #7)
>   - source tag should be fixed up according to 
>     https://fedoraproject.org/wiki/Packaging/SourceURL

Fixed.

>   - the description should be more than a repetition of the summary. 
>     Ideally 1-2 complete sentences.

I've added some more, uh, stuff.

> BuildRequires: missing PolicyKit-gnome-devel, libsexy-devel, intltool

Fixed.

> locale handling:
>   - you should use find-lang --with-gnome %{name}, then it also picks
>     up the translated docs and adds proper %locale tags for them

As I said, there are zero translations right now. So that's why it's commented
out right now. If included it fails. Maybe it's an upstream problem. I don't know.

>   - /usr/share/omf/palimpsest/ needs to be owned. See above for how to
>     fix that with find-lang

Please elaborate, ideally in patch(1) form.

>   - /usr/include/gnome-disk-utility/ must be owned 

Done.

Uploaded new SPEC and SRPM at same location. Thanks for reviewing this.
Comment 9 Matthias Clasen 2008-07-21 14:41:30 EDT
> Fine. It's now one byte. Stupid tools.

How odd. Wouldn't the obvious solution be to not ship a HACKING file if you
don't have one ?

> > BuildRequires: missing PolicyKit-gnome-devel, libsexy-devel, intltool
>
> Fixed.

You added a BR for PolicyKit-gnome, not PolicyKit-gnome-devel. I guess you'll
find out if thats sufficient... (turns out it is not)

have to run out now, will continue later
Comment 10 David Zeuthen 2008-07-21 14:53:43 EDT
(In reply to comment #9)
> > > BuildRequires: missing PolicyKit-gnome-devel, libsexy-devel, intltool
> >
> > Fixed.
> 
> You added a BR for PolicyKit-gnome, not PolicyKit-gnome-devel. I guess you'll
> find out if thats sufficient... (turns out it is not)

Of course it's not. Fixed. New SPEC and SRPM uploaded. Thanks.
Comment 11 Matthias Clasen 2008-07-21 16:05:10 EDT
> Please elaborate, ideally in patch(1) form.

Scratch that. find-lang.sh refuses to work if there are no translations.

Spec file looks fine now.
Comment 12 David Zeuthen 2008-07-21 16:29:12 EDT
New Package CVS Request
=======================
Package Name: gnome-disk-utility
Short Description: GNOME Disk Utility
Owners: davidz
Branches:
InitialCC:
Cvsextras Commits: yes
Comment 13 Kevin Fenzi 2008-07-22 11:54:20 EDT
cvs done.