Bug 458028

Summary: Keyboard layout selection not possible
Product: [Fedora] Fedora Reporter: Marc <m.chattle>
Component: system-config-keyboardAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jbgallagher2000, mclasen, notting, petersen, poelstra, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-24 15:53:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 438943    
Attachments:
Description Flags
Keyboard screenshot
none
UK keyboard selection
none
Keyboard selection now works none

Description Marc 2008-08-06 03:51:01 EDT
Description of problem:

Fedora 10 Alpha keyboard layout selection on login screen greyed out.  Also under 'Preferences' in Gnome, Keyboard layout window freezes and cannot select UK or any other keyboard.

Version-Release number of selected component (if applicable):

Latest Fedora 10 Alpha ISO downloaded and installed on the 5th August 2008 (from Chemnitz mirror).

How reproducible:

Tried to select keyboard several times, including after reboot.  Language selection on login screen does work.

Steps to Reproduce:
1. Tried keyboard selection at login screen and via preferences.
2. Repeated step above.
3. Repeated steps 1 and 2 both as user and root, and also after reboot.
  
Actual results:

Unable to select UK keyboard.

Expected results:

Expected to be able to select keyboard.

Additional info:
Comment 1 J Gallagher 2008-08-08 10:48:26 EDT
You can still change the keyboard from the system-config-keyboard applet, but it has been removed from the Gnome System->Administration menu since F9 (Why?) so must be launched from a terminal. It is still buggy however since it throws a selinux error when the keyboard is changed:

SELinux is preventing loadkeys (loadkeys_t) "read" to ./fedora (user_home_dir_t).

Fixing the (greyed out) keyboard selector on the Login screen will fix all these issues
Comment 2 J Gallagher 2008-08-08 10:50:22 EDT
You can still change the keyboard from the system-config-keyboard applet, but it has been removed from the Gnome System->Administration menu since F9 (Why?) so must be launched from a terminal. It is still buggy however since it throws a selinux error when the keyboard is changed:

SELinux is preventing loadkeys (loadkeys_t) "read" to ./fedora (user_home_dir_t).

Fixing the (greyed out) keyboard selector on the Login screen will fix all these issues
Comment 3 John Poelstra 2008-09-08 19:15:34 EDT
please paste the full message from setroubleshoot?
Comment 4 Marc 2008-09-10 09:50:33 EDT
Created attachment 316315 [details]
Keyboard screenshot

Unfortunately, from my point of view, there is neither a set troubleshoot message nor anything in the system log when this happens.  The best I can provide is this screenshot of what happens when I go to add a keyboard layout via the preferences in Gnome.
Comment 5 John Poelstra 2008-09-18 19:16:35 EDT
Are you still seeing this problem after updating to latest packages in rawhide?
Comment 6 Marc 2008-09-19 04:06:52 EDT
I've only just recently downloaded the updated package:

system-config-keyboard-1.2.15-3.fc10.noarch.rpm 

but haven't had a chance to test it yet.  Before I do, does it need any dependencies, and, if so, please could you tell me what I need to go with it so that I can download them also.  I'll test the update/s over the weekend.
Comment 7 Marc 2008-09-23 11:11:52 EDT
Just tried the package system-config-keyboard-1.2.15-3.fc10.noarch.rpm which was dated 16th September 2008 on the Red Hat development server, and it didn't work, but I noticed that it was the same package that came on the F10 Alpha disk.  I'm not sure why this is, but I'm guessing it is to do with the Fedora servers being breached recently, and packages being renewed and redistributed with updated keys?

I downloaded the system-config-keyboard-1.2.15-3.fc10.noarch.rpm package, dated 16th September from:

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/

Please could you advise me where I can find the updated system-config-keyboard package.
Comment 8 Matthias Clasen 2008-10-01 20:44:07 EDT
Please try the keyboard selection on the login screen again with the current rawhide packages. It should work now. 
Also, your problems seem entirely unrelated to system-config-keyboard
Comment 9 J Gallagher 2008-10-03 03:33:11 EDT
Fedora 10 Beta LiveCD (Gnome)

Keyboard selector on gdm login screen does not work for UK Keyboard (Haven't tested others)

I selected UK Keyboard, logged in, pressed shift 2 and got '#' rather than '£'.

But it's even worse now (!), since launching system-config-keyboard to make the change causes the cursor keys to stop working (!!) (it does change the rest of the keyboard to UK).

The only work-around involves enabling a persistence layer on a live usb, running system-config-keyboard and rebooting, upon rebooting the uk keyboard is properly working.


Summary:

The keyboard selector in Fedora 10 beta login screen is not working.
system-config-keyboard has a new bug which cause cursor keys to stop working.
Comment 10 J Gallagher 2008-10-03 03:34:01 EDT
^^^ that should have said "shift 3" not "shift 2"
Comment 11 Matthias Clasen 2008-10-04 02:33:28 EDT
Please try the keyboard selection on the login screen again with the current
rawhide packages. It should work now.
Comment 12 J Gallagher 2008-10-04 16:36:32 EDT
I'd need to rebuild the LivecD from the kickstart file wouldn't I?
Is there an easier way to test this on the F10 beta LiveCD (perhaps one or two package installs via yum, then I could test it by enabling a persistence overlay and rebooting)
Comment 13 Marc 2008-10-06 04:15:11 EDT
Just tried to install F10 Beta via the latest DVD, but it posted an anaconda bug with an output, which could not be copied to any disk, unfortunately, and consequently failed to install F10 onto the hard disk.  It also corrupted the CMOS, which needed to be cleared and re-set.  I'll have to wait for the final release of F10 before testing the keyboard selection again.
Comment 14 Will Woods 2008-10-10 11:41:49 EDT
We release weekly snapshots after Beta, leading up to a Preview Release a couple weeks before final. Surely you could test one of those?
Comment 15 Marc 2008-10-10 11:50:14 EDT
Yes, I could.  Please could you tell me where the snapshots are located, as I'm not sure exactly where they are.  I presume they are complete DVD images?  Thank you.
Comment 16 John Poelstra 2008-10-16 12:50:45 EDT
(In reply to comment #15)
> Yes, I could.  Please could you tell me where the snapshots are located, as I'm
> not sure exactly where they are.  I presume they are complete DVD images? 
> Thank you.

http://torrent.fedoraproject.org/
Comment 17 Marc 2008-10-20 04:28:55 EDT
Created attachment 320852 [details]
UK keyboard selection

Managed to get a copy of the F10 Snap 1 Live CD (i686) dated 10/10/2008, and the keyboard selection on the login screen works for selecting the UK keyboard.  

This only functions as far as the login screen, though (it is probably designed this way?).  When logged in, the keyboard layout needs selecting again through preferences, hardware, keyboard.  All the windows function now, and the UK keyboard can be selected.  There wasn't a DVD snapshot available when I visited http://torrent.fedoraproject.org/ previously, but I've just seen snapshot 2 with a DVD option, which I'll test from a full install.

However, for now, the live (Gnome) version works for keyboard selection for the UK option.

I also enclose the system log, for information, which relates to the time of this keyboard selection test.
Comment 18 Jens Petersen 2008-10-21 01:52:32 EDT
(In reply to comment #17)
> This only functions as far as the login screen, though (it is probably designed
> this way?).  When logged in, the keyboard layout needs selecting again through
> preferences, hardware, keyboard.

I believe this is fixed in gdm in current rawhide and snapshot 2 (bug 466429).
Comment 19 Matthias Clasen 2008-10-22 19:46:25 EDT
Yes, should be fixed.
Please reopen if it still doesn't work for you.
Comment 20 Marc 2008-10-23 04:03:15 EDT
Created attachment 321252 [details]
Keyboard selection now works

Tested F10 Snapshot 2 DVD (17/10/2008) on a full installation, and the keyboard selection on the login screen now works for UK selection as a user, and remains selected as the UK layout when logged into the user account.

Anaconda is still fragile, though, as it threw up a message similar to last time, but, unlike last time, I was able to install Snaphot 2 via the DVD after the second attempt.  I couldn't save the anaconda output to disk, but transcribed the first few lines in case they're any help:

Anaconda 11.4.1.49 exception report.  Traceback (most recent call first):  File”/usr/lib/anaconda/iw/netconfigdialog.py”, line67, in_netdev Changed val= combo.get_model(). Getvalue (active) Type error iter must be a GtkTreelter

The login screen also has a problem in that it doesn't recognize an attempt to login as root (other), so I couldn't test the keyboard selection as a root user.  I enclose the system log after first installation of snapshot 2 (DVD) for information.
Comment 21 Bill Nottingham 2008-10-24 15:53:20 EDT
The anaconda exception needs filed as a separate bug. 

gdm no longer allows root logins; this is intentional.

Good to see that keyboard selection works - closing.
Comment 22 Marc 2008-10-31 07:48:42 EDT
Thank you, anaconda bug reported separately (469339).