Bug 460585

Summary: update virtinst to install f10 xen guests
Product: Red Hat Enterprise Linux 5 Reporter: Cole Robinson <crobinso>
Component: python-virtinstAssignee: Cole Robinson <crobinso>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: clalance, gozen, mbelangia, mishu, orion, xen-maint
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-20 16:04:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Parse treeinfo file if located in tree and add f10 os entry none

Description Cole Robinson 2008-08-28 15:42:44 EDT
virtinst will need to be fixed to install fedora 10 xen guests. the only real solution is to backport the treeinfo parsing code and pull out the images-xen entry for PV guests.
Comment 1 RHEL Product and Program Management 2008-08-28 15:52:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Orion Poplawski 2008-09-04 18:44:23 EDT
I'm happy to test any rpms.  I'd really like to be able to install F10/rawhide on my EL5 machine.
Comment 4 Cole Robinson 2008-09-15 15:42:06 EDT
Created attachment 316777 [details]
Parse treeinfo file if located in tree and add f10 os entry
Comment 5 Orion Poplawski 2008-09-16 11:44:28 EDT
Hmm, doesn't apply cleanly to python-virtinst-0.300.2-8.el5:

patch -b -p1 < ~/virtinst-0.300.2-f10-treeinfo.patch 
patching file virtinst/FullVirtGuest.py              
Hunk #1 FAILED at 45.                                
1 out of 1 hunk FAILED -- saving rejects to file virtinst/FullVirtGuest.py.rej
patching file virtinst/OSDistro.py                                            
Hunk #2 succeeded at 51 (offset -1 lines).                                    
Hunk #3 succeeded at 109 with fuzz 2.                                         

FullVirtGuest.py fails because 0.300.2-8 doesn't list fedora9 as well.  Added that.

Then:

virt-install -n xenfdev64 -r 512 --vcpus=1 -m 40:00:00:00:00:03 --arch=x86_64 -p -f /dev/rootvg/xenfdev64 -l http://fedora.cora.nwra.com/fedora/linux/development/x86_64/os -x ks=http://sw.cora.nwra.com/ks/rawhide-nox64.cfg
Would you like to enable graphics support? (yes or no) yes


Starting install...
__init__() takes at most 4 arguments (5 given)
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start xenfdev64'; otherwise, please
 restart your installation.
Tue, 16 Sep 2008 09:26:45 ERROR    __init__() takes at most 4 arguments (5 given)
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 502, in ?
    main()
  File "/usr/sbin/virt-install", line 462, in main
    dom = guest.start_install(conscb,progresscb)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 811, in start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 56, in _prepare_install
    self._installer.prepare(guest = self, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 239, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 209, in _prepare_kernel_and_initrd
    distro = distro)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 115, in acquireKernel
    scratchdir=scratchdir)
  File "/usr/lib/python2.4/site-packages/virtinst/DistroManager.py", line 60, in _checkRHDistro
    store = FedoraDistro(baseuri, type, scratchdir)
  File "/usr/lib/python2.4/site-packages/virtinst/OSDistro.py", line 55, in __init__
    Distro.__init__(self, uri, type, scratchdir, arch)
TypeError: __init__() takes at most 4 arguments (5 given)

so, dropped arch from Distro.__init__:

        Distro.__init__(self, uri, type, scratchdir)



Now to get images-xen fixed in .treeinfo again...
Comment 6 Cole Robinson 2008-09-16 11:51:29 EDT
Sorry, should have mentioned that this was applied dependent on some other changes.

You will probably need to apply the patches in bz 448634 and bz 449129 in order for this to apply cleanly. :( Lot's of mucking around in this section of the code it seems.
Comment 7 Orion Poplawski 2008-09-16 11:53:09 EDT
Is there a final src.rpm somewhere I could get?
Comment 8 Cole Robinson 2008-09-18 17:01:12 EDT
This is built in python-virtinst-0.300.2-10.el5. Setting to MODIFIED.
Comment 9 Orion Poplawski 2008-09-18 17:02:58 EDT
Is there somewhere I can get a copy of python-virtinst-0.300.2-10.el5?
Comment 12 Daniel Berrange 2008-11-11 13:52:10 EST
*** Bug 471079 has been marked as a duplicate of this bug. ***
Comment 17 errata-xmlrpc 2009-01-20 16:04:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0216.html