Bug 448634 - Scientific Linux not recognized as a valid OS
Scientific Linux not recognized as a valid OS
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks: 449772
  Show dependency treegraph
 
Reported: 2008-05-27 20:00 EDT by Wart
Modified: 2009-12-14 16:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add support for scientific linux guests (1.79 KB, patch)
2008-05-27 20:00 EDT, Wart
no flags Details | Diff
python-virtinst-0.300.2-12.el5 to allow SL sites as guests (639 bytes, patch)
2009-02-05 17:48 EST, Troy Dawson
no flags Details | Diff

  None (edit)
Description Wart 2008-05-27 20:00:28 EDT
Description of problem:
virt-install fails when trying to install Scientific Linux 4.6 as a
paravirtualized guest, claiming that it can't find an installable image.

Version-Release number of selected component (if applicable):
python-virtinst-0.300.2-8.el5

How reproducible:
Always

Steps to Reproduce:
1. Run virt-install against a scientific linux installation tree with 'virt-inst
-n foobar -l http://my.os.tree/sl/4.6/x86_64'
  
Actual results:
virt-inst fails with the error:
ValueError: Could not find an installable distribution at
'http://newman.ultralight.org/os/scientificlinux/4.6/x86_64'

Expected results:
sl 4.6 install proceeds normally
Comment 1 Wart 2008-05-27 20:00:28 EDT
Created attachment 306857 [details]
Patch to add support for scientific linux guests
Comment 2 Troy Dawson 2008-06-03 16:21:48 EDT
Just so you know, this patch works for Scientific Linux 5.
It works much better than the patch that was originally in SL 5.0 and 5.1.
Comment 3 Cole Robinson 2008-06-24 12:20:47 EDT
Thanks! I've committed a variant of this upstream:

http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=0784ae04ac12

If you want the patch submitter wants to send me a full name I'll add you to the
authors list. Also I'll make sure this is pulled in for 5.3
Comment 4 Wart 2008-06-24 12:24:09 EDT
(In reply to comment #3)
> Thanks! I've committed a variant of this upstream:
> 
> http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=0784ae04ac12
> 
> If you want the patch submitter wants to send me a full name I'll add you to the
> authors list. Also I'll make sure this is pulled in for 5.3

Feel free to list me as Michael "wart" Thomas

Thanks, and I look forward to this in RHEL 5.3.
Comment 5 RHEL Product and Program Management 2008-06-24 14:04:24 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Daniel Berrange 2008-06-24 14:38:23 EDT
I'm really not sure that Scientific Linux really needs an explicit entry in
virt-manager.  It is a distro derived from RHEL and as such the exact same
settings used for the RHEL option should work just fine. For that matter we
should arguably kill the CentOS option in the menu too. 
Comment 7 Cole Robinson 2008-06-24 14:54:20 EDT
The entire distro detection scheme needs to be overhauled anyways. Since we have
the ability to test for file existence without grabbing, we can sidestep the
whitelist activity and just directly touch the xen boot kernel or pxeboot
kernel, or in the case of say SLES whatever crazy files we need to hack together
for a boot kernel.
Comment 8 Daniel Berrange 2008-06-24 14:59:20 EDT
The distro stuff is for more than just where to grab files - it also controls
what hardware devices are configured by default. eg USB graphics tablet, UTC vs
localtime for clock, and  IDE vs VirtIO for disk config, so we can't avoid it -
these are the kind of features that are identical across all derived distros
Comment 9 Cole Robinson 2008-06-24 15:04:03 EDT
Right, I misread your comment a bit. I was refering to the whole
detect-a-distro-from-an-install-tree action. I actually didn't add scientific
linux as an entry in the big os list, and I agree we should condense down centos
as well to just fall use rhel.

Speaking of the big OS list though, I wouldn't mind trying to slim that down a
bit. We are looking at a situation in a couple years where we'll have entries
for fedora 5-14 among other things.
Comment 10 Cole Robinson 2008-06-26 16:12:34 EDT
From a qa perspective, to test this, use the command:

virt-install --name sltest -r 256 --nodisks --paravirt --nographics --location
http://ftp.scientificlinux.org/linux/scientific/46/x86_64

Prior to the patch this should fail with 'Installable distribution not found'.
After the patch this command should succeed.
Comment 11 Cole Robinson 2008-09-14 20:05:24 EDT
Okay, fix is in python-virtinst-0.300.2-9.el5. Setting to MODIFIED.
Comment 14 errata-xmlrpc 2009-01-20 16:05:15 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0216.html
Comment 15 Troy Dawson 2009-02-05 17:45:59 EST
python-virtinst-0.300.2-12.el5, which comes with RHEL 5 Update 3, works for 90% of Scientific Linux versions.  But it doesn't work with their "sites", or derivatives.  It almost works though.   The problem is that for DistroManager.py, you check for SL.releasenote, which should work in all cases.  But in OSDistro.py you check for just the directory SL, which fails for "sites".
I am including a patch which checks for SL.releasenote in both OSDistro.py and DistroManager.py.    We are also checking for "Scientific Linux" in .treeinfo, like you are doing in other releases, but not for Scientific Linux.
Comment 16 Troy Dawson 2009-02-05 17:48:30 EST
Created attachment 331061 [details]
python-virtinst-0.300.2-12.el5 to allow SL sites as guests
Comment 17 Cole Robinson 2009-02-06 10:26:43 EST
Could you provide an example of a failing URL?

Note You need to log in before you can comment on or make changes to this bug.