Bug 465389

Summary: Fedora rawhide (Fedora 10 Beta) intel vga drivers failure
Product: [Fedora] Fedora Reporter: Yovko Ilchev Yovkov <yyovkov>
Component: xorg-x11-drv-i810Assignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: medium    
Version: rawhideCC: erik, evilastharoth, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-07 12:09:14 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 457945    

Description Yovko Ilchev Yovkov 2008-10-02 23:01:30 EDT
Description of problem:
Unable to start X Server

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-8.fc10.i386

How reproducible:
Boot system in init 3 and at command prompt after login type "startx"

Steps to Reproduce:
1. Boot the system in init 3.
2. Login into the system as ordinary user or root.
3. Type "startx" command at command promptd.
  
Actual results:
/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/drivers//intel_drv.so: undefined symbol: intel_bufmgr_fake_init
^Cgiving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  unexpected signal 2.

Expected results:
The X server should start and graphical interface should be accessible

Additional info:
Comment 1 Matěj Cepl 2008-10-06 19:29:57 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Yovko Ilchev Yovkov 2008-10-07 14:20:06 EDT
Unfortunately I am not able to send you requested files, as I have downgraded my mobile to F9.
If till the end of the next week no one can give you such logs I will have time to manage another upgrade.

regards,
Yovko Yovkov
Comment 3 Erik P. Olsen 2008-10-24 06:13:48 EDT
I believe I have the same problem with rawhide (of 10/24). It boots correctly to mode 3 but won't start X. There is no /etc/X11/xorg.conf on the system. My video card is Matrox MGA G550 and I've noticed during anaconda that it didn't look for the video card. Somehow it has build a system with a crippled X server.
Comment 4 Filippo Racca 2008-11-05 20:27:01 EST
I have a similar but worse problem with Fedora 10 live preview release on a notebook with intel 855 graphic card. When trying to start Xorg without an xorg.conf file I get a black screen and the system freeze. After that I can only power off the notebook. If I boot in runlevel 3 and then create an xorg.conf file specifying the "vesa" driver I can run the X server.

This is the working (with vesa) xorg.conf I created:

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105+inet"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	ModelName    "LCD Panel 1024x768"
	HorizSync    31.5 - 48.0
	VertRefresh  56.0 - 65.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "vesa"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

If I put under Driver "intel" Xorg freezes the whole system.
Comment 5 Yovko Ilchev Yovkov 2008-11-06 23:15:26 EST
I had time to update again my Fedora 9 to Fodora rawhide. Now my video card working correctly.

PC: Sony Vaio VGN-NR180E:
--- cut ---
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
	Subsystem: Sony Corporation Device 902d
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at fc000000 (64-bit, non-prefetchable) [size=1M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
	Capabilities: [d0] Power Management version 3
	Kernel modules: intelfb
--- cut ---
Comment 6 Matěj Cepl 2008-11-07 12:09:14 EST
Closing per the reporter's comment
Comment 7 Filippo Racca 2008-11-08 12:32:56 EST
I updated F10 preview release (but couldn't restart with the new kernel see that I'm using a live image) but the problem remains. The system still freeze. But a doubt remains: could it be that the new hal and/or kernel solved the problem for Yovko Ilchev Yovkov? And not for me because I couldn't reboot with the upgrades? I managed to get via ssh the xorg.log after the freeze with "intel" driver. I posted it here (https://bugzilla.redhat.com/show_bug.cgi?id=470152) if you want to take a look. Or if it's more comfortable for you I can attach it here too.