This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 470152 - Fedora 10 Preview DVD i386 fails on HP DC7700 on first boot
Fedora 10 Preview DVD i386 fails on HP DC7700 on first boot
Status: CLOSED DUPLICATE of bug 444328
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 18:32 EST by linux.ninja1
Modified: 2009-09-21 10:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 10:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dc7700 anaconda that generates no xorg.conf in /etc/X11 (1.46 KB, text/plain)
2008-11-06 15:07 EST, linux.ninja1
no flags Details
xorg.conf that works with "vesa" driver but causes total freeze with "intel" (801 bytes, text/plain)
2008-11-06 15:36 EST, Filippo Racca
no flags Details
xorg.log with "intel" driver (26.64 KB, text/plain)
2008-11-08 12:13 EST, Filippo Racca
no flags Details

  None (edit)
Description linux.ninja1 2008-11-05 18:32:23 EST
Description of problem:

First : during the graphic anaconda installation only a small portion of the screen is used instead of going full screen.

Secondly : after the installation is finished you can select Reboot but then on first boot, the screen goes black at the end of the moving status bar.   No way to switch to another console but using ssh from another box I was able to login remotely.   I did not find an xorg.conf file and after using yum install system-config-display i created a xorg.conf file but that did not seem to fix the problem.


Version-Release number of selected component (if applicable):
fresh install of Fedora 10 Preview from DVD

How reproducible:
On a HP 7700 just do the most basic installation (next/next/next) and the problem is easily reproducable.


Steps to Reproduce:
1.fresh install on DC7700
2.take all the default option during anaconda
3.frist reboot
  
Actual results:


Expected results:
a graphical login screen

Additional info:
Fedora 8 and 9 did do a correct discovery of the graphic capabilities.
chipset is a intel 965
Comment 1 linux.ninja1 2008-11-05 18:43:00 EST
HP DC 7700    / HP DC7700
Comment 2 Filippo Racca 2008-11-05 20:42:58 EST
I think this is exactly the same problem I have with a notebook with an intel 855 graphic card and Fedora 10 live preview release. Maybe this bug and this (https://bugzilla.redhat.com/show_bug.cgi?id=465389) are related.
Comment 3 Matěj Cepl 2008-11-06 11:40:51 EST
Everybody, please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 linux.ninja1 2008-11-06 15:07:20 EST
Created attachment 322780 [details]
dc7700 anaconda that generates no xorg.conf in /etc/X11

after first reboot I can not find a /etc/X11/xorg.conf file.
This is the anaconda-ks.cfg file of a plain dc7700 install with the issue.
Comment 5 linux.ninja1 2008-11-06 15:21:31 EST
again a fresh install

no Xorg.conf file in /etc/X11 found

after first boot a black screen but still accessable with SSH

using ssh -X root@server

I first did a 
yum install system-config-display
and changed to init 3 in /etc/inittab
and the a reboot

After the reboot in init 3 i tried on the server console itself
startx
but again black screen and no way to get out of it

after a reboot
I tried to run system-config-display from the server console itself but again black screen


after a reboot 
I tried to run system-config-display via a ssh -X root@server and at least I could use the tool to configure X but after a reboot again black screen


Same hardware works without problems in FC 8,9
Comment 6 Filippo Racca 2008-11-06 15:36:12 EST
Created attachment 322784 [details]
xorg.conf that works with "vesa" driver but causes total freeze with "intel"

This is the xorg.conf that manages to starts Xorg (with vesa driver).It's very basic. If I put "intel" as driver or if no xorg.conf is present in /etc/X11 trying to start Xorg results in a total freeze of the system.
Comment 7 Filippo Racca 2008-11-06 15:40:17 EST
Unfortunately I can't post the xorg.log file: I'm using a live version of Fedora 10 preview release and after Xorg freezes the only option left is to reboot manually the machine thus destroying the xorg.log file.
Comment 8 Matěj Cepl 2008-11-07 18:06:21 EST
(In reply to comment #7)
> Unfortunately I can't post the xorg.log file: I'm using a live version of
> Fedora 10 preview release and after Xorg freezes the only option left is to
> reboot manually the machine thus destroying the xorg.log file.

Cannot you get to the machine via ssh? If yes, then take a look both into both /var/log/ and /tmp directories, in some  parts of the loading of the disc some logs hide in both places.
Comment 9 Filippo Racca 2008-11-08 12:13:38 EST
Created attachment 322957 [details]
xorg.log with "intel" driver

Xorg.0.log file taken via ssh from the frozen machine after trying to start gdm with "intel" driver.
Comment 10 linux.ninja1 2008-11-10 07:10:19 EST
A long weekend and nonstop raining outside so I tried the Fedora 10 Preview CD instead of the DVD and Fedora 10 actually comes up beautifully with the CD edition ...
 
But I don't see a Xorg.conf file in /etc/X11 either.

Definitely different behaviour and results between CD and DVD editions.
Comment 11 Filippo Racca 2008-11-10 15:55:12 EST
xorg.conf is no more needed by the new xorg server it should choose the best configuration for your hardware (unless you happen to have some problem, like me for instance :-)
Comment 12 Filippo Racca 2008-11-14 20:19:13 EST
Today I installed F10 preview into the hd. After a global update Xorg managed to start without xorg.conf (and without vesa)! So I think we can close this bug (unless there will be regressions before F10 release date, but let's hope not!). I have only a little problem with characters visualization (I only see half of them) on screen that disappear only if I choose subpixel shading. I don't exactly love subpixel shading but I think I can bear with it until the next update (or file a new bug here at bugzilla). Thanks for all the attention!
Comment 13 Filippo Racca 2008-11-14 20:22:59 EST
Well, A little problem remains: the driver is extremely slow! With glxgears on F10 I obtain 130 fps while on F9 it was 510...And glxgears and glxinfo give this error message: [intel_init_bufmgr:592] Error initializing buffer manager.
Comment 14 Bug Zapper 2008-11-25 23:50:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Vedran Miletić 2009-09-21 10:20:49 EDT
Closing as a duplicate of 444328 per comment #13.

*** This bug has been marked as a duplicate of bug 444328 ***

Note You need to log in before you can comment on or make changes to this bug.