Bug 466573
| Summary: | Apache HTTPD server fails to start with error on mod_perl | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Harold Pritchett <harold> |
| Component: | httpd | Assignee: | Joe Orton <jorton> |
| Status: | CLOSED DUPLICATE | QA Contact: | Fedora Extras Quality Assurance <extras-qa> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | rawhide | CC: | jorton |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2008-10-20 16:01:20 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Today I did a completely new install of Fedora 10 from the DVD on a different disk. I did a "yum update" and then tried to start the httpd server. Same error message, This time, I only have one copy of mod_perl installed... [root@bolt ~]# rpm -qa | grep mod_perl mod_perl-2.0.4-6.i386 [root@bolt ~]# *** This bug has been marked as a duplicate of bug 459351 *** |
Description of problem: When starting the Apache HTTPD server, the following error message is generated and the start fails... [root@bolt conf.d]# service httpd start Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax error on line 10 of /etc/httpd/conf.d/perl.conf: Cannot load /etc/httpd/modules/mod_perl.so into server: /etc/httpd/modules/mod_perl.so: undefined symbol: modperl_io_perlio_restore_stdout [FAILED] [root@bolt conf.d]# Version-Release number of selected component (if applicable): I seem to have two versions of mod_perl installed... [root@bolt modules]# rpm -qa | grep mod_perl mod_perl-2.0.4-6.i386 mod_perl-2.0.4-5.i386 [root@bolt modules]# How reproducible: every time Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info: rename /etc/httpd/conf.d/perl.conf to perl.conf.no and the server starts ok... Fedora 10 system was installed from downloaded DVD image and then updated via yum yesterday. Today, yum updates fail (see 466482). output of uname -a Linux bolt.halshome.net 2.6.27-0.398.rc9.fc10.i686 #1 SMP Mon Oct 6 22:23:41 EDT 2008 i686 i686 i386 GNU/Linux