Bug 459351 - mod_perl-2.0.4-5.i386.rpm won't load into httpd
mod_perl-2.0.4-5.i386.rpm won't load into httpd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
: 465743 466573 (view as bug list)
Depends On:
Blocks: 465037
  Show dependency treegraph
 
Reported: 2008-08-17 05:09 EDT by Jonathan Kamens
Modified: 2008-10-20 12:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 06:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-08-17 05:09:47 EDT
With current rawhide, trying to start httpd:

Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax error on line 10 of /etc/httpd/conf.d/perl.conf: Cannot load /etc/httpd/modules/mod_perl.so into server: /etc/httpd/modules/mod_perl.so: undefined symbol: modperl_io_perlio_restore_stdout

Reverting to mod_perl-2.0.4-4.i386 makes the problem go away, although I have to do it with "--nodeps" because otherwise I get these odd errors from RPM:

	perl(ModPerl::FunctionMap) is needed by mod_perl-2.0.4-4.i386
	perl(ModPerl::MapUtil) is needed by mod_perl-2.0.4-4.i386
	perl(ModPerl::StructureMap) is needed by mod_perl-2.0.4-4.i386
Comment 1 Jonathan Kamens 2008-08-28 12:02:50 EDT
Still broken in todays' Rawhide.
Comment 2 Bruno Wolff III 2008-09-06 20:51:41 EDT
I am still seeing this in the 2008-09-05 rawhide. Since I really don't need mod_perl, I just commented out the load so that httpd starts.
Comment 3 Mads Kiilerich 2008-10-02 13:42:22 EDT
Same with F10 mod_perl-2.0.4-6.i386

Just installing the package causes httpd to fail starting. IMHO this bug is such a showstopper that it should be a release blocker.
Comment 4 Nils Philippsen 2008-10-09 14:48:58 EDT
*** Bug 465743 has been marked as a duplicate of this bug. ***
Comment 5 Nils Philippsen 2008-10-16 09:40:16 EDT
Joe, FYI: when I compiled the package, I found that the symbol doesn't even end up in the src/modules/perl/modperl_io.lo file because it should be inlined -- maybe something goes wrong with inlining it?

Do you need any other info?
Comment 6 Joe Orton 2008-10-17 06:32:04 EDT
The use of inline in mod_perl was completely broken - I've removed it and rebuilt.

http://koji.fedoraproject.org/koji/buildinfo?buildID=66644
Comment 7 Nils Philippsen 2008-10-17 11:52:56 EDT
Works for me with mod_perl-2.0.4-7.
Comment 8 Joe Orton 2008-10-20 12:01:21 EDT
*** Bug 466573 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.