Bug 467913

Summary: Please add a dependency on usermode-gtk
Product: [Fedora] Fedora Reporter: Sebastian Vahl <fedora>
Component: system-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: davidz, fedora, harald, jmoskovc, kevin, mclasen, mitr, rdieter, than, tmraz, tuxbrewr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-27 10:18:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 446449, 457945, 466768    

Description Sebastian Vahl 2008-10-21 13:25:53 EDT
+++ This bug was initially created as a clone of Bug #466768 +++

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pt-BR; rv:1.9.0.2) Gecko/2008100707 Fedora/3.0.2-1.fc10 Firefox/3.0.2

I'm running kde 4.1.2 and am trying to access administration tools without success. Whenever i launch one of these tools that requires privileged access, the cursor bounces on screen, the task bar shows the icon from the window, but after some seconds it's dismissed and the cursor stops bouncing and no windows is opened. When i try this on konsole, i got a prompt asking my password and the window is opened. This happend with almost any system-config tool that needs password to open.

These doesn't work:
 - /usr/bin/system-config-network
 - /usr/bin/system-config-boot
 - /usr/bin/system-config-date
 - /usr/bin/system-config-firewall
 - /usr/bin/system-config-language
 - system-config-printer
 - /usr/bin/system-config-lvm
 - /usr/bin/system-config-selinux
 - /usr/bin/system-config-rootpassword
 - /usr/bin/system-config-display
 - /usr/bin/system-config-users

These is the one that actually worked:
 - /usr/bin/system-config-services
 - /usr/bin/system-control-network

These are from System menu and doesn't work also:
 - /usr/bin/selinux-polgengui

Reproducible: Always

Steps to Reproduce:
1. Install Fedora 10 KDE LiveCD
2. Go to Administration menu and click on one of the items
3. Watch the cursor bounce without any window opening
Actual Results:  
Cursor bouncing, icon on task bar and no window;

Expected Results:  
On Fedora 9, the cursor used to bounce, the task bar used to show the icon and after awhile the window asking my password used to open. This is the expected result on Fedora 10, i think.

Don't know what else i can provide. But if you ask, i will.

--- Additional comment from mclasen@redhat.com on 2008-10-15 18:38:15 EDT ---

Most of these tools have nothing at all to do with PolicyKit.

Tentatively moving to KDE, since "running under KDE" seems to be the only common factor here...

--- Additional comment from kevin@tigcc.ticalc.org on 2008-10-15 18:47:07 EDT ---

consolehelper from usermode-gtk is what these tools use to get root.

Is there anything new in F10 we have to do in KDE to get consolehelper to work?

--- Additional comment from than@redhat.com on 2008-10-16 07:39:22 EDT ---

i have latest rawhide (today) running on my test machine. I cannot reproduce this problem. It seems something is broken in Fedora 10 KDE LiveCD?

--- Additional comment from rdieter@math.unl.edu on 2008-10-16 07:49:54 EDT ---

Or that the system-* tools or usermode has missing deps.

--- Additional comment from edneymatias@gmail.com on 2008-10-16 08:02:46 EDT ---

I think maybe Rex ir right cause i have a gnome-session installed even when i installed from kde live cd and the system-* tools doesn't work there too.

--- Additional comment from mitr@redhat.com on 2008-10-16 15:35:19 EDT ---

Do you have usermode-gtk installed?  (Run (rpm -q usermode-gtk) in a terminal.)

--- Additional comment from edneymatias@gmail.com on 2008-10-16 22:50:40 EDT ---

Nop, i didn't have usermode-gtk. I installed and everything worked. So something is wrong with kde live? 

BTW thank you for your support.

--- Additional comment from kevin@tigcc.ticalc.org on 2008-10-16 22:53:08 EDT ---

So the bug is that those tools are all missing a dependency on usermode-gtk?

--- Additional comment from kevin@tigcc.ticalc.org on 2008-10-16 22:54:36 EDT ---

CCing Sebastian Vahl, the KDE live CD maintainer, he may want to manually pull in usermode-gtk onto the spin. (Still, I think there should be a dependency if the tools aren't going to work without it!)

--- Additional comment from than@redhat.com on 2008-10-17 06:09:30 EDT ---

there's only a dependency on usermode but not on usermode-gtk in the system tools. I will fix it in our system tools.

--- Additional comment from fedora@deadbabylon.de on 2008-10-17 06:17:23 EDT ---

(In reply to comment #10)
> there's only a dependency on usermode but not on usermode-gtk in the system
> tools. I will fix it in our system tools.

Ok then. Or should I also add it to the kickstarts?

BTW: It is possible that the applications design of the system-config-tools has changed in some way? What I mean: I could start system-config-services and it seems to be working. If I want to disable a service there, a PoliciKit window pops up and asks me for the root password. system-config-date and system-config-firewall want's this password before starting the application.

--- Additional comment from kevin@tigcc.ticalc.org on 2008-10-17 07:14:20 EDT ---

Looks like system-config-services has been ported to use PolicyKit instead of running as root entirely, system-config-date and system-config-firewall are still using usermode-gtk (which runs the entire application as root). That's also why system-config-services works without usermode-gtk and the others don't.

--- Additional comment from than@redhat.com on 2008-10-17 07:23:43 EDT ---

only system-config-services and system-config-samba supports PolicyKit and the rest not.
Comment 1 Sebastian Vahl 2008-10-21 13:34:10 EDT
Uh, sorry. I should have edited this text before cloning the bug. So here's the problem described in fewer words:

This package is currently missing a dependency on usermode-gtk. So on systems
where this isn't installed (like the current KDE live images) this package
isn't working properly as a non-root user from the menu.